1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1600 to 1500 swap in 91 Civic EX non VTEC

Discussion in 'HYBRID -> ED-EF / DA' started by papajohn51, Sep 12, 2006.

  1. papajohn51

    papajohn51 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 12, 2006
    Friend of mine burned up his 1600, blew a bypass hose and blew head gasket. Cylinders are black and glazed...
    Not sure of the correct designation, B or D,, so I'll apologize up front. I have the old engine so I can look it up and post it later if need be. Anyways he bought a JDM Twin Carbureted 1500, said thats all he could find at the time. So I figured let's try it out. So I installed the 1500 long block. Everything seemed to fit, except the 1600 had a oil cooler at the base of the filter which is not there on the 1500. Distributor on the 1500(new one) had a vacuum controlled distributor. Hmmm
    I put all the intake(MPI) stuff from the 1600 on the 1500 and all seems fine... starts and runs great. except, the computer is displaying error codes for the O2 and the MAP sensors. Car will run fine on flat roads, chugs and dies on hills. New fuel filter and o2 sensor did nothing to help.
    So I am wondering if someone has ever done this swap before? I wonder if I need the vacuum advance dist? Not sure at this point if I can swap the computer or??
    Hopefully someone can shed some light on this problem.
     
  2. Mr.Gerbil

    Mr.Gerbil Check your six

    Messages:
    21
    Likes Received:
    0
    Joined:
    Aug 30, 2006
    Are you using the vacuume advance dizzy?

    You should be using the stock electronic adv. distributor because it should work with that head.
     
  3. papajohn51

    papajohn51 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 12, 2006
    I am using the 1600 electronic 'dizzy' , as you call it:)
    This engine is a D15B, was carbureted, but now has all the EFI stuff from the old 1600. I disconnected the battery, to reset the computer, because it wasnt reset after installing a new 02 sensor,, seems like it is running better. Hmmm,,
     
Verification:
Draft saved Draft deleted

Share This Page