1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1995 honda civic

Discussion in 'Civic and del Sol - EG and EK' started by shon, Jun 2, 2010.

  1. shon

    shon New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 2, 2010
    car wont start i hear the fuel pump move then its just a click sound, i bought a brand new starter and still same thing. the motor wont even turn over so what do i do??
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Main relay? Starter fuse? Bad wiring?
     
  3. shon

    shon New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 2, 2010
    but it happen cause of a puddle of water
     
  4. A Ryan

    A Ryan New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jun 3, 2010
    Hydro Lock Maybe

    If your using a cold air intake system that doesnt have a hydro bypass filter that could have sucked in sum water.

    My eg hatch did that, i just kept holdin the key starting it to turn it over until the water made it out of the system.......this might drain your battery tho
     
  5. Magana559

    Magana559 The Warden

    Messages:
    2,568
    Likes Received:
    42
    Joined:
    Aug 9, 2008
    Location:
    fresno Ca
    I really hope you didnt banana a rod, Pull ALL the spark plugs and crank it. should shoot water out. crank it untill you see no more water and replace the plugs. try to start. Make sure there is no water in the oil.
     
  6. RoughKnight

    RoughKnight Christmas Car

    Messages:
    846
    Likes Received:
    25
    Joined:
    Aug 4, 2009
    Location:
    Ottawa, Ont
  7. autox 89 dx

    autox 89 dx Member

    Messages:
    332
    Likes Received:
    8
    Joined:
    Mar 21, 2008
    Location:
    SF bay area
    if you have a air intake take the filter off then try to start it. The same thing happened to me before.
     
  8. ilovekandypaint

    ilovekandypaint resident paint pro

    Messages:
    37
    Likes Received:
    12
    Joined:
    Jun 13, 2010
    Not sure if the eg's have this problem, but I had a ef that would do this exact thing sometimes, it was a relay, I unscrewed it let it hang and when it didn't crank, I would tap it with my foot while turning it over and it would fire right up. Eventually I bought a new one
     
  9. chadcharb

    chadcharb Well-Known Member VIP

    Messages:
    3,005
    Likes Received:
    294
    Joined:
    Oct 15, 2008
    Location:
    maple valley, Wa
    pull your dist cap and make sure theres no water in there. i cleaned my engine bay a while ago and got water in there. just dry it out and youll be good to go
     
Verification:
Draft saved Draft deleted

Share This Page