1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1st gear is really slow!!!!

Discussion in 'Forced Induction' started by DESPAIN, Jun 5, 2009.

  1. DESPAIN

    DESPAIN yep....mmhhm.......yep...

    Joined:
    Aug 1, 2008
    Messages:
    1,703
    Likes Received:
    39
    Location:
    flower mound TX
    ok i have a jdm h22 fully built block; ie: forged pistons h-beam rods, 780cc injectors...... boosted. now i went to the track the other day and my take off is reallly slow. almost feels like turbo lag??? what can i do to take off faster?
    Last edited: Jun 5, 2009
  2. phyregod

    phyregod !!YTINASNI

    Joined:
    Jun 11, 2005
    Messages:
    9,397
    Media:
    2
    Likes Received:
    213
    Location:
    Central Texas
    Could it be.... Turbo lag? lol. Got to spool that bitch up!

    Other than that, check out your timing?
  3. DESPAIN

    DESPAIN yep....mmhhm.......yep...

    Joined:
    Aug 1, 2008
    Messages:
    1,703
    Likes Received:
    39
    Location:
    flower mound TX
    how do i spool it up? just rev. it up before lights start?
  4. !JDM_EF-9!

    !JDM_EF-9! I'm just EF'n..

    Joined:
    Jul 8, 2007
    Messages:
    528
    Likes Received:
    6
    Location:
    cailfornia
    2 step would work..
  5. 95b16coupe

    95b16coupe New Member

    Joined:
    Nov 6, 2008
    Messages:
    6,538
    Likes Received:
    222
    Location:
    ct
    you need to work on getting the power to the ground.

    we discussed this in your other thread. you need lsd, better tires, traction bars, etc.

Share This Page