1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2-bolt post doesn't match 2-bolt driver's side mount?!

Discussion in 'HYBRID -> EG-EK / DC' started by Curlybandit, Oct 4, 2017.

  1. Curlybandit

    Curlybandit Member

    Messages:
    38
    Likes Received:
    27
    Joined:
    May 31, 2017
    Hey everyone.

    I'm having an issue with my swap. For reference, I'm getting an OBD1 JDM GSR b18c motor swapped into my '93 del Sol Si. It had a d16z6 and I was using Innovative Mounts engine mounts with 75A poly.

    I contacted Innovative Mounts to confirm if their driver's side 2-bolt mount will work with the b18. Their website indicates that the mount is for both D and B motors. They replied that it would.

    Unfortunately, the offset bolts and the holes of the mount don't line up. I've attached a pic.

    Has anyone seen this before? Any suggestions on how to resolve this?

    Thanks!
     

    Attached Files:

  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,545
    Likes Received:
    266
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Maybe they sent you the wrong one? They did that to me before- send them the pic and they're really good at responding quickly- I had a new mount in just a couple days when I got the wrong one putting a 5G D block into a CRX.
     
  3. Curlybandit

    Curlybandit Member

    Messages:
    38
    Likes Received:
    27
    Joined:
    May 31, 2017
    I did a little digging. When I bought the motor I had the supplier install a two-bolt post onto the motor to mount up with the two-bolt engine mounts I had. It turns out that the post may be from an older generation GSR. I got the correct part number and I've ordered the correct post. It should be arriving tomorrow.
     
  4. dilbeckskate

    dilbeckskate infamous

    Messages:
    4,233
    Likes Received:
    406
    Joined:
    Aug 20, 2010
    Location:
    Kennesaw Ga
    could be wrong mount, could be needing to loosen up the other mounts to give some wiggle room to line up
     
  5. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,545
    Likes Received:
    266
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    At least you figured it out quickly!
    That's a LOT of wiggle...
     
Verification:
Draft saved Draft deleted

Share This Page