1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

5$ paypal for anyone that can help solve this prob

Discussion in 'General Tech and Maintenance' started by Jdubspeeds, Dec 15, 2004.

  1. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    The check engine light inst coming on when you turn the key to on. and the ecu does not blink to show that it is working? I replaced the main relay and tested the distributor and they are both fine. What am I missing. Why wont this ecu turn on? I have tried another of my ecus and it wont turn on eithier.
     
  2. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    im asuming you check than main battery fuse and others
     
  3. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa



    I looked and didnt see any grounds near that the thermostat
     
  4. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa


    yeah i checked the fuses
     
  5. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,623
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    check the bulb on the back of the cluster. check to see if its there first. if its there, then try another bulb.
     
  6. Judo_boy_48

    Judo_boy_48 Senior Member

    Messages:
    218
    Likes Received:
    0
    Joined:
    Feb 14, 2003
    I think he meant his ECU isn't working. Not the bulb.

    Maybe use a multimeter to see if your getting any voltage to the ECU?
     
  7. friz

    friz Senior Member

    Messages:
    519
    Likes Received:
    2
    Joined:
    Jan 9, 2003
    Location:
    OZ


    The grounds at the engine and the strap from the engine to the chassis is very important. I would look in this direction. Power to the unit is not important if you don't have a ground path.
     
Verification:
Draft saved Draft deleted

Share This Page