1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

86 crx si troubleshooting

Discussion in 'Civic and CRX - EW' started by skipntampa, Nov 8, 2006.

  1. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    My newly aquired 86 crx si, has developed a problem, me thinks. I was on my way home, and the red PGM-FI light on the cluster lit up. I pulled into a gas station, and turned the car off, filled up, and drove back home, light did not come on again. When it was lit up, I noticed it idled up near 1500 rpm, usually the idle is at 800-900 rpm.

    I just bought this car yesterday, and know nothing about it. Anyone have an idea whats going on? Is it safe to drive? The light didnt come back on.

    For reference, it has 186k on it, runs pretty fine. I was pushing it a lil hard, earlier before the light came on, before that I was just Interstate driving.
     
  2. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    Oh and another thing, I had the heater on while I was driving, and it was very hot down near my feet... dont know if that has anything to do with it, but after I stopped, I turned the heat off, and thats when I noticed the light never came back on...
     
  3. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    probably an intermittent problem (most likely O2 sensor) and no, it won't hurt to drive it - look at the ECU (it is under the passenger seat) and see if it is showing codes - it has 4 LEDs on the side of the ECU - when you have a check engine light, the ECU stores the codes - once you turn off the ignition the check engine light goes out and when you turn it back on, if the problem was intermittent, the check engine light won't reappear, but the codes will usually (not always) still be in the ECU
     
    Last edited: Nov 9, 2006
  4. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    where can I find the codes, so I know whats wrong?
     
  5. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    here you go: (kind of fuzzy pix, but i think you can read them)

    [​IMG]

    [​IMG]
     
  6. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    thats awesome dude, could you email me the original scans?
     
  7. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
  8. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    so, it looks as if I have a code 1....thats oxygen sensor? can I buy a replacement from the parts store, or Honda?
     
  9. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    get one from parts store - you can get a universal one for about $20 and you will have to put a connector on it so that it will plug in or you can get one with connector already on it, that plugs right in, for $42

    http://www.partsamerica.com/ProductList.aspx?parttype=291&ptset=A&searchfor=Oxygen+Sensor
     
  10. skipntampa

    skipntampa Skippy

    Messages:
    27
    Likes Received:
    0
    Joined:
    Nov 6, 2006
    Location:
    Florida
    dude, your the man....
     
Verification:
Draft saved Draft deleted

Share This Page