1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

88 crx si b16a swap wiring question

Discussion in 'HYBRID -> ED-EF / DA' started by ccr88crx, May 1, 2007.

  1. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    im doing a b16a vtec swap in a 88 crx si the thing im stuck on is, on the driver side of the engine the wiring harness that runs to the resistor box has the small two pin plug that hooks to the resistor, but the bigger round 10 pin connector, what is it for?

    i compared it to my buddies crx si and his plugs into a mateing connector. my connector that this is supose to mate with ony has 8 wires and is square.

    do i need this and if so what do i do
     
    Last edited: May 1, 2007
  2. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    If it's a OBD1-2 B16A you don't even need to hook up the resistor box(the injectors are already saturated). That connector(I assume the one with yellow wires, correct?) connects all the wires together(should be a plug in there).
     
  3. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    the thing is there are 8 wires comeing off the engine in that connector, but the plug it is supose to plug into only has 6 and is the wrong plug. should i just hard wire them same color to same color and if so what are the other two
     
    Last edited: May 2, 2007
  4. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    the two wires that i dont know were they go on the harness off the engine (driver side) are dark blue and black with yellow stripe were the hell do they go.
     
    Last edited: May 2, 2007
  5. jason22ga

    jason22ga jason91si

    Messages:
    65
    Likes Received:
    0
    Joined:
    Feb 5, 2007
    Location:
    griffin,ga
    i had the same problem with the b16a wiring harness i used my factory si harness and had to extend a couple of wires and run 4 wires for vtec,vtec oil pressure,knock sensor,and 2nd 02 sensor very simple to do if this is your problem let me know and ill get with you about fixing it
     
  6. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    ive got the four that you are talking about figured out. the one im talking about is the distributor harness there is a black/yellow (ign output) and a Blue (tach output) where do they need to go.
     
  7. jason22ga

    jason22ga jason91si

    Messages:
    65
    Likes Received:
    0
    Joined:
    Feb 5, 2007
    Location:
    griffin,ga
    what harness are you using
     
  8. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    hell i dont know im just going to get a book and go off that

    thanks though if i have any more questions ill get back to you

    im new at this whole honda swap thing
     
    Last edited: May 2, 2007
  9. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
  10. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    PICTURE OF RESISTOR BOX!!

    [IMG]http://i29.photobucket.com/albums/c291/Jay_Kid/RESISTORBX.jpg[/QUOTE][/IMG]


    this is the harness connector
     
  11. hondaman85

    hondaman85 Large Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Apr 23, 2007
    Location:
    C town
    dont use b16 wire harness thats the problem I had to figure out you need you factory si wire harness and it will work.
     
  12. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    the 88 Si had a square 6 wire connector - the 89-91 Si had a round 8 wire connector because the 89-91 had a Fast Idle Control Valve on the back of the intake manifold, which the 88 didn't have - the wire colors for the FICV are blue and black/yellow - all of the other wire colors are the same on the 88s and the 89-91s - the blue and black/yellow wires at the distributor do not go thru the driver's side connector - they go thru the passenger side connector - you can't use the B16A engine harness on the USDM car - the wires are different - you need to use the engine harness that came on your car
     
    Last edited: May 3, 2007
  13. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    if i use the b16a harness what do i do with the wires that are for the fast idle control valve (blue and Black/yellow) do they hook up to the computor or what. they have to go some where. or do i even need them cuz if i use the harness that came with the car its not going to have them wires from what your telling me.
     
  14. ccr88crx

    ccr88crx New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    May 1, 2007
    we got it running with the harness you told use not to use but now we have an error code on the ecu the red light blinks 9 times what is this code and how do we fix it
     
Verification:
Draft saved Draft deleted

Share This Page