1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

90 civic hatch stalls

Discussion in 'Civic and CRX - EF' started by sub95, Jan 9, 2007.

  1. sub95

    sub95 Junior Member

    Messages:
    66
    Likes Received:
    0
    Joined:
    Apr 9, 2003
    Location:
    Cali
    It's a 90 civic hatch DX D15B2, dual point. after the car warms up and you come to a stop it dies, if i give it gas ( to the floor sometimes ) or feather it, it will run in stay running . other then this the car runs great.

    The car is new to me just picked it up. it has codes, 6 temp sender which works?. 7 tps how do i go about replacing it, has no srews/bolts to take it off just rivets. 16 injector there only two so how do i find out which one is bad?



    Thanks for any help you can give.
     
  2. sub95

    sub95 Junior Member

    Messages:
    66
    Likes Received:
    0
    Joined:
    Apr 9, 2003
    Location:
    Cali
    TPS reads .74 volts at idle and 4.34 at full throttle.
     
  3. sub95

    sub95 Junior Member

    Messages:
    66
    Likes Received:
    0
    Joined:
    Apr 9, 2003
    Location:
    Cali
    Got the codes fixed, but it still does the same thing after it warms up you go up around 45+ coming to a stop it sputters then dies, there are no codes.
     
  4. racer_XX

    racer_XX New Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Dec 13, 2006
    try ur idle air control. ur throttle plate is closed when ur off the gas. ur idle air control is supposed to let air bypass and if its broken or stuck it wont let in enough air and ur car will sputter and die.
     
  5. sub95

    sub95 Junior Member

    Messages:
    66
    Likes Received:
    0
    Joined:
    Apr 9, 2003
    Location:
    Cali
    Update

    well checked everything out and it's okay so i took it for another drive and it did it again grr well by now there is only a 1/4 tank of gas with all the driving i have been doing to get back to my house there is a steep hill i have to go down well just for the heck of it i pushed the clucth in to let it idle well it died got back to flat road and it started right back up. make a long story short the fuel pump is bad
     
Verification:
Draft saved Draft deleted

Share This Page