1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

90 Civic Si speed cable

Discussion in 'Civic and CRX - EF' started by Vtecmonster08, Nov 30, 2008.

  1. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    I just bought a cable that is suppost to go from the back of the tac to the tranny to see how fast im going , and i pluged it in and the speed still dosnt show?can any one help?
     
  2. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    the motor for that car is a d16z6 Sohc Vtec from a 95 ex coupe.
     
  3. 1991_civic_si

    1991_civic_si New Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Nov 24, 2008
    is it a aftermarket cable i had a prelude and i got a cable and the part that went to the cluster was too small so it didnt work so check that out
     
  4. Schock3

    Schock3 Junior Member

    Messages:
    89
    Likes Received:
    0
    Joined:
    Jun 6, 2006
    ive been looking for a speed cable where did u get it from??
     
  5. GlassHeadlights

    GlassHeadlights West West Yall

    Messages:
    4,066
    Likes Received:
    71
    Joined:
    Oct 24, 2007
    Location:
    Calgary, AB
    eBay is your cheapest option.



    So you have the stock tranny for your car right?

    Are you sure both sides are put in all the way and correctly, and are you sure you didn't put in in backwards?
     
  6. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    a little old but the d16z6 has an electronic speed sensor,and the cluster in the ef's are set for mechanical..
     
  7. Schock3

    Schock3 Junior Member

    Messages:
    89
    Likes Received:
    0
    Joined:
    Jun 6, 2006
    na its a b16a i cant find the cable that was supposed to be behind the cluster it most likley got ripped out
     
  8. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana
    i have a 91 dx with a b16. i pulled the speed sensor outta the trans and just plugged the cable driven speedo in. worked so far.
     
  9. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana
    im glad i found this thread cause my 90 si with a d15b is havin speedo problems. the needles wavin up and down and its makin a rubbing noise as i drive sounds like when your scratching your fingernails on a pair of jeans. vrrrrt vrrt vrrt vrrt vrrt vrrt vrrt vrrrt just like that annoying!! is there any easy fix or do i need a new cable?
     
  10. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana

    is the drive gear down all the way? you have the lil metal tab holdin it in right?
     
  11. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    Ok yes its an EF but it was automatic ..LOL...and i got the right cable from another D16z6 but when i connect it to the tranny and then to the cluster it wont catch or "READ" for that mater....now whats this i hear of "ITS electronic" is this true? am i fucked? because if its is how the hell am i going to make that work......?

    92 eclipse GS....blown motor
    90 civic SI....
     
  12. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    the ef cluster is gear driven,and the z6 is electronic sensor,
     
  13. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    Well then ummm.....what the hell does everyone else do?What do i do to make it work..because driving with a tom tom that show's your speed is getting wack..lol..
     
  14. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana

    ur using a cable right? auto ef cluster correct?
     
  15. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    Yup the car was deff. auto and the weird thing is that the cable fit perfect in the back of the cluster and fits perfect inside of the tranny but it dont work.....what do think i should do?


    90 civic si
    d16z6 1.6L Vtec
    Headers
    AEM intake
    straight PIPE
    Vacf
    short shift
    stage 2 clutch
    MSD
     
  16. Schock3

    Schock3 Junior Member

    Messages:
    89
    Likes Received:
    0
    Joined:
    Jun 6, 2006
    take it out and soak the cable in wd-40 or some kind of lubricant for about 20 mins u should be good after that.
     
  17. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana

    imma try that when it gets warmer...sure hope its that easy cause routing a new cable thru the dash sucks!!
     
  18. Vtecmonster08

    Vtecmonster08 Vtecmonster

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 28, 2008
    Location:
    Las Vegas
    anyone have options for me?
     
  19. Schock3

    Schock3 Junior Member

    Messages:
    89
    Likes Received:
    0
    Joined:
    Jun 6, 2006
    the speed cable teeth might be fucked up in the trans. take it out and look
     
  20. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana
    where the drive gear goes in the trans does it look like this?? hers the cable attatched to the gear. of course yours will most likely be black not yellow


    [​IMG]
     
Verification:
Draft saved Draft deleted

Share This Page