1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

90 civic Si won't start help please

Discussion in 'Civic and CRX - EF' started by fixed4 life, Jan 7, 2013.

  1. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    I have a 90 civic Si that I bought 2 years ago. Saturday I drove it to work and back with no problems. It sat till Sunday night I tried to drive it and it wouldn't start. Main relay is less than a year old. The fuel pump primes and I pulled a spark plug out and I see spark. If I keep cranking the engine it acts like it wants to start sometimes. This morning I kept cranking it till it finally started it ran for about a minute and then just shut off. I know there are tons of post about this all over forums but thought I would try again with this post. Thanks for reading.
     
  2. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    Also it's not throwing any codes. The LED on the ecu does blink once when I turn over the key but nothing else after that.
     
  3. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    Here's an update. Took the cap off the distributor and the screw that holds the rotor in place had came loose and fell out. Bought a new cap and rotor and its running like a champ now!
     
    Last edited: Jan 7, 2013
Verification:
Draft saved Draft deleted

Share This Page