1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

90 si no go

Discussion in 'Civic and CRX - EF' started by EFDX, Feb 7, 2010.

  1. EFDX

    EFDX New Member

    Messages:
    65
    Likes Received:
    1
    Joined:
    Jan 17, 2009
    91 si had intermittant no go, now its not running at all, car is bone stock, it has spark, has fuel pressure, no CEL, strong battery, full of coolant, ran well until it didnt start
    any ideas welcomed and apretiated
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    ecu
     
  3. singlecamcrx

    singlecamcrx New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Feb 7, 2010
    check the harness on the passenger side strut tower. To see if the main wires are wet, lose or the relay is bad
     
  4. jowilson275

    jowilson275 91' Si B16A

    Messages:
    123
    Likes Received:
    4
    Joined:
    Feb 3, 2010
    if its a crx, ecu is forward passenger side floor
     
  5. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
  6. EFDX

    EFDX New Member

    Messages:
    65
    Likes Received:
    1
    Joined:
    Jan 17, 2009
    after about 30 mins of trying to start it, it finally put out a code, code 15, i swaped the ignitor from a b18a1 in the dizzy and it runs now, thanx
     
  7. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    weird that you has spark and fuel this whole time.
     
  8. BrokenRex

    BrokenRex New Member

    Messages:
    388
    Likes Received:
    10
    Joined:
    Mar 21, 2008
    if this ever happens again, the first thing to check is the main fuel relay. the solder in there cracks over time, happens very often. the second thing to check is the distributor. obd0 honda distributors suck, especially in hot climates. glad you got yours running so quickly.
     
  9. EFDX

    EFDX New Member

    Messages:
    65
    Likes Received:
    1
    Joined:
    Jan 17, 2009
    i first suspected the relay but i swapped it out with a known good one but it still did not go, so i put the original one back in. i even opened them up to compare... i don't know if the ignitor unit in the dizzy gradually weakens to failure, or just fails but it took quite a while to set a code, btw i swapped the spark plugs from my daily 90 DX with the ones from the SI after the ignitor swap but before i attempted to see if the ignitor swap worked...but the SI plugs are runnig fine in my DX, also the SI has a blown head gasket...basically what im saying is i don't know if the plugs made the ignitor fail, but i wouldn't be suprised
     
Verification:
Draft saved Draft deleted

Share This Page