1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

91 civic stall when pressing on gas?

Discussion in 'General Tech and Maintenance' started by grimremember, Jul 24, 2012.

  1. grimremember

    grimremember New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jun 1, 2012
    i have a 91 civic hatch that stalls everytime i press on the gas idk what could be causing it, the car is also running very rich could that be the cause? i've been told to change the fuel filter but i dont see how that would help if the car is already getting too much fuel...?
     
  2. grimremember

    grimremember New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jun 1, 2012
    also the car when first turned on will idol very low and then after about 30 seconds it will go to about 1-1.2k and then stay there till i touch the gas and then stalls
     
  3. josh_crewdson@y

    josh_crewdson@y New Member

    Messages:
    438
    Likes Received:
    4
    Joined:
    Dec 5, 2007
    Location:
    nova
  4. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    153
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Yes....X2. You gotta have a CEL....it's your little helper trying to assist you in a right direction.

    I'll stab at it. Oxygen Sensor.
     
  5. grimremember

    grimremember New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jun 1, 2012
    no no cel but when i pull off the map it idols normal and is drivable so i'm thinking a bad map sensor?
     
  6. grimremember

    grimremember New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jun 1, 2012
    Okay something new that does not make sense to me.... i got a new map sensor plugged it in car ran like shit and stalled when pressed on gas however i unplug it car runs fine and if i plug the map sensor in while the car is running it continues to run fine like nothing ever happened... its ONLY when the map sensor is plugged in and i try to start the car when it runs bad im so confused???
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    153
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I know that the MAP & TPS are constantly talking to one another.

    Check the volts on the TPS with key to "on" but motor shut off.

    1) closed throttle volt reading. (should be real close to 0.45v)
    2) wide open throttle volt reading. (should be real close to 4.5v)
     
  8. grimremember

    grimremember New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jun 1, 2012
    i know the tps is new aswell but i dont have access to a volt meter is there any other thing to check?
     
Verification:
Draft saved Draft deleted

Share This Page