1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

92 civic ex o2 sensor issues

Discussion in 'Civic and del Sol - EG and EK' started by skellagher, Jul 10, 2010.

  1. skellagher

    skellagher Elder Driver

    Messages:
    256
    Likes Received:
    1
    Joined:
    Oct 18, 2007
    Location:
    Newark, De
    ok so my buddy has a 92 ex auto and he was throwing a cel code 41 for o2 sensor he replaced the o2 sensor and reset the ecu to clear the codes but it was still going on so i go over there to maybe figure it out but come to find out his ex has a p07 ecu which from my understanding is from a VX? but i had him exchange the o2 sensor and put the new one in and reset the ecu again but same issue code 41 pops up again. so what the hell do i do? could the ecu be causing the issue i mean it didnt have the code about 2 weeks ago but this has become a troubling issue for me because now i am truly stumped :confused:
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    1992 EX Sedan should have a D16Z6 motor (engraved on the motor by the trans) and a P28 ECU

    Check the code on the motor first. But if its a D16Z6....he has the wrong ECU (which seems really weird). Not sure on all the different VX models but I thought they had 2 O2 sensors? One near the head on the exhaust manifold and one on the downpipe??

    Either you thought it was the wrong motor (and got the wrong O2) or its the D16Z6 and he has the wrong ECU
     
  3. skellagher

    skellagher Elder Driver

    Messages:
    256
    Likes Received:
    1
    Joined:
    Oct 18, 2007
    Location:
    Newark, De
    yea thats what made me determine it was the wrong ecu the engine stamp is the first thing i checked and sure enough its a d16z6 and i know it needs an auto p28 ecu
     
  4. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    So it was running with the VX ECU and things were fine before? Thats weird
     
  5. skellagher

    skellagher Elder Driver

    Messages:
    256
    Likes Received:
    1
    Joined:
    Oct 18, 2007
    Location:
    Newark, De
    thats what he says anyway but the vx has a six wire o2 sensor to my understanding so i dont see why it would ever work
     
  6. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I have read a variety of O2 sensors....dont know what to believe. Just check the ECU and go from there
     
Verification:
Draft saved Draft deleted

Share This Page