1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

92 vx w/cel code 1

Discussion in 'ECU's, Electronics, and Tuning' started by thepartsguy, Feb 2, 2009.

  1. thepartsguy

    thepartsguy New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 29, 2009
    Just did a d16z6 swap into a civic vx and i'm running a stock p28. I got a code 1 after i drove for about 5 minutes, I cleared up the code and tried it again. The 02 sensor is brand new, so i know it's not that. My friend let me borrow his p28 and i drove it for a good half hour and no CEL came on.

    I want to know if anyone has ran into this problem?
    Does code 1 mean 02 and/or bad ECU?
    Is it the ECU?
    Are there different p28's?
    Are there different 4 wire 02 sensors?
    Or did i get scammed on the ECU i bought?
    Is there any way to find out how to re-assure myself that the ecu is bad?
    I don't want to ask for a refund untill i'm a 100% sure it's the ECU?

    Any help/opinion is appreciated!
    THANKS
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    primary 02 sensor is code 1. if its not a honda 02 sometimes they just dont work. and if your using the vx harness it has a 5 wire 02 the p28 needs a 4 wire 02
     
  3. thepartsguy

    thepartsguy New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 29, 2009

    Well it's an aftermarket 02 sensor, but what do you think about the other ecu working fine and this ecu throwing the code 1?
     
  4. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    how many wires is your o2 sensor
     
  5. thepartsguy

    thepartsguy New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 29, 2009

    4 wire
    :confused:
     
  6. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    well the p28 should be fine
     
  7. thepartsguy

    thepartsguy New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 29, 2009


    Thanks for the feedback, but i guess i got a bad ecu.

    Just wanted to see if anyone had ever ran into code 1 and it not being 02 sensor.
     
  8. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    so you and your friend both have bad ecu.i doubt both of them being bad
     
Verification:
Draft saved Draft deleted

Share This Page