1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

93' Civic won't start

Discussion in 'General Tech and Maintenance' started by vicflo, Sep 8, 2009.

  1. vicflo

    vicflo New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Aug 22, 2009
    Location:
    South Florida
    I have a 93' Manuel Civic EX coupe 1.6 liters with the D16Z stock engine. Just recently when you turn the ignition key(key position 2) without cranking the engine, the check engine light comes on normally to run it's self test of the ECU. The check engine light stays on anywhere from about 45 seconds to 4 minutes. When it finally turns off, you can hear the fuel pump turn on and the car will then start. I've had this car for 15 years and it normally did this test within 1-2 seconds. The ignition switch has been giving me problems in turning the key to start the car or to remove the key from the switch(getting stuck). Could this be a cause of this problem? Thanks in advance for any comments that would help.
     
  2. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Main relay would be my guess.
     
  3. vicflo

    vicflo New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Aug 22, 2009
    Location:
    South Florida
    I changed the Main Relay and had the same result.
     
Verification:
Draft saved Draft deleted

Share This Page