1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

93 hatch with b18b swap

Discussion in 'HYBRID -> EG-EK / DC' started by Ritzbitz, Mar 22, 2012.

  1. Ritzbitz

    Ritzbitz New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 21, 2012
    Ok guy I have a 93 eg hatch with a 95 b18b manual rumning off a p73 with ls stock maps. Im having an idle problem when I run the car hard ( switching gear at 5k). When I come to a stop my idle drops down to about 400 and car bogs but doesn't stall. I can drive it but it hesitates and feel like it misfires, I have to turn the car off and start it back up and everything goes back to normal (idle goes to 900 and no hesitation). If I drive the and swift a 4k it won't do it. Any suggestion on where to start?
     
  2. primeredseol

    primeredseol New Member

    Messages:
    41
    Likes Received:
    0
    Joined:
    Feb 10, 2012
    maybe the fast idle thermo valve (FITV) on the bottom of the throttle body, needs to be cleaned and the plunger tightened. Thats where i'd start.
     
  3. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    the vibration at high rpm's could cause fitv plunger screw to lossen , so you need to clean and tighten screw like prmeredseol said ,good tip bro,lol....
     
  4. Ritzbitz

    Ritzbitz New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 21, 2012
    It's clean and tight and still have the problem.
     
  5. Ritzbitz

    Ritzbitz New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 21, 2012
    I got it fix the chip in the ecu had a bug. All good now though thanx
     
Verification:
Draft saved Draft deleted

Share This Page