1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

94 EX w/ Ls Vtec swap questions..

Discussion in 'HYBRID -> EG-EK / DC' started by TurboCivic, Jul 3, 2007.

  1. TurboCivic

    TurboCivic 468fwhp B21 on 22 psi...

    Messages:
    113
    Likes Received:
    0
    Joined:
    Sep 15, 2003
    Location:
    Spokane, WA
    Hey as it says I have a 94 civic ex and I put a ls vtec in it. The motor runs ok up until where vtec is supposed to kick, once it hits vtec the motor feels like it hits a rev limiter...I have perfect oil pressure, its all wired up correctly, when I changed vtec to a different point it does the same thing. When I disable vtec the motor will rev up to wherever I set it at, 9k. I am out of ideas on this, could it be internal? if so what could it be? I am out of ideas, help....:(
     
  2. invisibledemon

    invisibledemon Bored Moderator VIP

    Messages:
    7,402
    Likes Received:
    626
    Joined:
    Jan 15, 2007
    Location:
    Tn
    did you properly build the ls.vtec? tap the head for the oil holes? any CEL'S?
     
  3. dtob

    dtob New Member

    Messages:
    578
    Likes Received:
    2
    Joined:
    Mar 18, 2007
    Ya it doesn't sound like the engine is seeing the oil pressure at the vtec sending unit. Then when the vtec is supposed to engage it doesn't. I had the same problem with my mini me when I put my P28 in and didn't have the sensor hooked up.
     
  4. TurboCivic

    TurboCivic 468fwhp B21 on 22 psi...

    Messages:
    113
    Likes Received:
    0
    Joined:
    Sep 15, 2003
    Location:
    Spokane, WA
    yea, its all done right, and no CEL's. any help?
     
  5. invisibledemon

    invisibledemon Bored Moderator VIP

    Messages:
    7,402
    Likes Received:
    626
    Joined:
    Jan 15, 2007
    Location:
    Tn
    im assuming you have a vtec controller bc you said you changed it to a different point. all i can say is double check all of your wiring and make sure everythings hooked up.
     
  6. TurboCivic

    TurboCivic 468fwhp B21 on 22 psi...

    Messages:
    113
    Likes Received:
    0
    Joined:
    Sep 15, 2003
    Location:
    Spokane, WA
    no vtec controller, I have an ostrich, and all wiring is correct, went through it yesterday, my vtec solenoid works and it tries to hit vtec but something isnt letting it, like mechanically. What in the head would not let the lobes switch? cause without vtec I can rev to whatever I set it at. But with vtec when it tries to engage something is stopping it....
     
Verification:
Draft saved Draft deleted

Share This Page