1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

95 accord h22a need help

Discussion in 'Accord' started by 95h22Accord, Mar 24, 2011.

  1. 95h22Accord

    95h22Accord New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 24, 2011
    to start it off i am pretty new to the whole honda world. traded a bike for this accord. its a 1995 accord with a 93 JDM H22a motor. it didn't start when i got it, the person i got it from just wasn't to smart and should of checked the starter.

    after i got it started and drove it for a few days i decided to get on it to engage vtec i realized the Vtec does not engage. ive changed the oil and spark plugs. checked the codes and the ecu was throwing code 22 and code 6. i found a wiring diagram and followed some wires. the vtec oil pressure switch was not plugged into the right spot. changed it around and fixed code 22. code 6 still appears. i ran more wires and found that the ECT was plugged in where the vtec oil pressure switch was supposed to be (idk why) before it was unplugged to fix code22. when i plugged the ECT in the correct spot it left another plug unplugged. the CEL will not appear anymore but the car will not run right(it will start and idle real high and start to lower, as soon as i rev it up and let off the gas the rpms drop and bounce and almost kills the car). if i plug the other plug back into where the ECT goes, the car will run fine but the CEL will come back on and vtec wont engage. goin to take some pics will post them soon.. if anyone has some ideas please let me kno.. thanks
     
  2. 95h22Accord

    95h22Accord New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 24, 2011
    [​IMG]
    after following the wires to the ecu i found this to be my ECT

    [​IMG]
    this is where my ECT should be plugged into. when i do this the CEL does not come on and the ecu does not throw any codes.

    [​IMG]
    with all the right things connected it leaves this plug open

    [​IMG]
    this is the set of wires that were plugged into where my ECT is supposed to be plugged. if these are not plugged into where my ECT is supposed to be the car will not run right. if i plug it back in to where the ECT goes the car runs fine but the CEL comes on again and no vtec. i followed the all green wire and the black ground. the green wire leads to the alternator control pin on the ecu. any help would be appreciated..
     
  3. 95h22Accord

    95h22Accord New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 24, 2011
  4. JUNGLE SHOP

    JUNGLE SHOP New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 6, 2011
    I have a 1996 accord ex and im puttin a h22a in it . Does the harness from the accord match up to the h22a or do i need to change it? And what do i do with the crank sensor?
     
  5. 95h22Accord

    95h22Accord New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 24, 2011
    As much as I kno the accord harness should work u just have to extend some wires. I don't really kno much about the swap I'm still learning.

    Not much from this site tho cuz I havent got any answers from anyone... I still have the same problem I did 3 weeks ago. (Guess people are just as stumped as me)

    Good luck tho.
     
  6. doug808

    doug808 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Apr 9, 2011
    I have a vtec and the same sensor is not CONNECTED. I THINK IT DOESN'T MATTER BECAUSE BOTH WILL GET A READING. I MIGHT BE WRONG THOUGH GOOD LUCK
     
  7. 95h22Accord

    95h22Accord New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 24, 2011
    Thanks. I noticed there is a few plugs that don't run to anything. But I wanna get everything striaght first then just eliminate the plugs I don't use.
     
  8. pjschmitt

    pjschmitt New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Nov 14, 2009
    what ecu are you using? Is it for the knock sensor? The wiring diagram should give you a clue. The fact that it is a single pair of wires is another thing to help eliminate any three wire connectors. On my engine, I have a 94 H22A. It is using the 94 accord f22b harness slightly modified.

    we have one connector on the:

    water neck in the front which is black for two wires

    water neck on the rear that is purple for two wires

    head which is white for two wires

    solenoid which is green for two wires.

    the harness should help a little by the way it is wrapped up so that it reaches the right connectors.

    Try the farthest and the shortest.

    There is also the purge on the firewall.


    I would use a meter and see what the wires tell me. First across them for voltage and then maybe the resistance.

    This info and a manual will help you to rule out some possibilities and allow you to determine where it goes by the process of elimination.
     
  9. goose34

    goose34 New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Sep 14, 2010
    hey bro i have a h22 and worked on it for a while. the grey plug is for the ect. the green plug is for the vtec pressure switch. now you have to hook up your vtec pressure switch to your ecu. ecu pinout D6. if that dont work then let me know. its only one wire to the ecu. one is a ground. ground it to the thermostat.
     
  10. iLLest11

    iLLest11 New Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Sep 28, 2011
    that wire u have in your hand is the one thats on the f22 waterneck infront of the car the h22 doesent have it but the water neck from the f22 does fit. the vtec pressure switch wires are light blue and black that connector looks more like a temp sensor to me..good luck on your swap tho im havving problems with mine too
     
Verification:
Draft saved Draft deleted

Share This Page