1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

95 civic hatch with jdm swap I NEED HELP!!

Discussion in 'Engine Building' started by oneslowhatchback, Nov 20, 2003.

  1. oneslowhatchback

    oneslowhatchback Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 20, 2003
    im new here, but i need a little help. i have a 95 civic hatch cx and i just put a jdm d15b 1.5/1.6 vtec in the thing. i bought a vtec ecu and a rs type vtec coontroller. im almost possitive that i have it hooked up correctly. the place i bought the motor from said all i would have to do was get the ecu and the controller and use pin a4 out of ecu to vtec selonoid and pin d6 to vtec oil pressure control switch. i did all that. computer throws code 21 which is vtec selonoid. my o2 sensor is bad i know and must replace it. but my prob is the vtec is not engaging. ive tested the selonoid with +12 volt and i get the clicking sound,blah,blah. but no vtec when driving. can someone pleeeasee help me. im desperate. ive been under the hood of this thing after work, everyday for 2 months now. tips and directions would be appreciated. oh and i still have the cx stock trans in it. someone said that could be part of my prob. im looking in to gettting a 95 del sol si tranny.
    thanks though to whom ever can help me
    email or post please
    until then......
    jsaon
    spotted@comcast.net
     
  2. h22bubbleback

    h22bubbleback Senior Member

    Messages:
    1,559
    Likes Received:
    0
    Joined:
    Jul 18, 2003
    Location:
    North Jerzey
    def. not ur trans.....i had the same problem..code 21 and everything u were explaining...my oil pressure sensor was faulty..check that but dont take my word on it..see what other people post first..im not really sure ur prob could be differnt.
     
  3. oneslowhatchback

    oneslowhatchback Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 20, 2003
    yeah just spent $80 bucks on a new oil pressure control switch and it made no difference. so thats not it. but thanks for responding.
    im almost tired of working on it, but i love the hatchback, its such a fun car with tons of potential
    until then......
    jason
     
  4. cws13

    cws13 Senior Member

    Messages:
    484
    Likes Received:
    0
    Joined:
    Nov 15, 2002
    Location:
    Athens,GA
    have you checked continuity across the wire?
     
  5. highperboi

    highperboi Senior Member

    Messages:
    971
    Likes Received:
    0
    Joined:
    Dec 2, 2002
    Location:
    Alameda, California
    maybe you didnt wire the vtec controler right? take it out and see what happens.
     
  6. theB16tegguy

    theB16tegguy Senior Member

    Messages:
    245
    Likes Received:
    0
    Joined:
    Sep 18, 2003
    Location:
    charlotte, NC
    unplug the vtec controller. I've known people who have installed them wrong, like when you add fuel it actually decreases fuel and all kinds of crazy shit. I heard something from a honda mechanic last night. he said that a cars speedo has to work for the Vtec to engage. I told him that I didn't think it would apply to a cable speedo.(what I have) but if yours is electronic that could be the problem.
     
Verification:
Draft saved Draft deleted

Share This Page