1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

95 civic

Discussion in 'Civic and del Sol - EG and EK' started by chrismoses, Apr 8, 2009.

  1. chrismoses

    chrismoses New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    I have a 95 civic and will not go over 4600 rpm driving or sitting sounds like its running rich any ideas?:mad:
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Bad sensors
    Bad ECU
    Bad distributor

    More info on your setup would be helpful...

    And welcome to HondaSwap!
     
  3. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Welcome would agree with the above... btw are u taking it out of 1st haha j/k
     
  4. chrismoses

    chrismoses New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    new distributor changed the ecu still the same. I changed the tps,map, some one said maybe the pressure switch or the vtec valve
     
  5. chrismoses

    chrismoses New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    it has the minime swap 2.5 catback exhaust t3/t4 turbo 3bar map sensor 460 injectors chipped ecu. I had the problem since I put the engine back into the car and all I did was rebuild it.
     
  6. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Maybe something was miss allined or your timing mite be off??? Other question is who chipped the ECU?? could your problem there
     
  7. chrismoses

    chrismoses New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    its the same motor i had last year ran awsome. I just putted it out to rebuild it the common civic honda problem smoking.
     
  8. chrismoses

    chrismoses New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    It is the same motor I had last year I just rebuilt it common honda problem smoking
     
  9. daniel99208

    daniel99208 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 11, 2009
    H23A1 swap

    I have a 95 honda civic w/ a 1.6 non-vtec and just got a H23A1 engine, what would I need to swap it; would it fit?
     
  10. YBLEGAL

    YBLEGAL Regular Member w/ Cheese

    Messages:
    2,762
    Likes Received:
    36
    Joined:
    Aug 9, 2006
    Location:
    NW Indiana
    Learn to use a forum. Start your own thread. This doesn't relate to the topic...
     
  11. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    I would look into Maybe a fault in your wiring some were, just maybe, have u tryed to rev it up by hand? or better yet just un plugged a few of the sensors ?
     
Verification:
Draft saved Draft deleted

Share This Page