1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

95 GSR problems

Discussion in 'General Tech and Maintenance' started by ep3kid510, Oct 10, 2006.

  1. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    so I was driving around and took it to about 6krpms then suddenly I started losing power, tach kept goin past 7k but I was slowing down still. Then i slowed down next thing you know the car stalled.. :confused: I noticed the oil level low indicator was blinking so I added about 2.5 quarts. Next I did a compression test, all cylinders came up to about 185+. Started it back up then the motor started making this "clucking" noise. At first it only happens when Im not pressing on the clutch. Now it makes that noise at idle. I drove it home but I kept stalling (shit was hella loud) the only way that i could make it go was to keep my foot slighty on the gas while I start it. Anyone know what could be my problem?
     
  2. f22b1 coupe

    f22b1 coupe Junior Member

    Messages:
    346
    Likes Received:
    14
    Joined:
    Dec 30, 2005
    Location:
    Indiana
    Haha, well, I'm not sure that is an "add oil" light so much as it is a "low oil pressure" light. Sounds like a blown head gasket maybe.
     
  3. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    lol I work on F-18 hornet. Thats the warning I get whenever im troubleshooting the jet. Anyways, im a noob when it comes to cars
     
  4. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,622
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    sounds like you starved the engine of oil, revved it out when you had no oil pressure and now you fucked your bearings and your knocking. sounds like its time for a rebuild
     
  5. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    that's what i thought too.... btw, how much does it cost for a rebuild?
     
  6. myah

    myah Neu Impact Performance

    Messages:
    226
    Likes Received:
    1
    Joined:
    Jul 21, 2006
    Location:
    ks
    ok dosen't sound like you need a rebuild you should check your map sensor cause thats what was happening to me the stalling part and i replaced my map sensor and the problem was gone
     
  7. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    will do... but whats up with this clucking noise coming from my valve cover?
     
  8. myah

    myah Neu Impact Performance

    Messages:
    226
    Likes Received:
    1
    Joined:
    Jul 21, 2006
    Location:
    ks
    have you check your valve spring yet make sure that their are torqued to the correct torque and i think that should solve your problems and check your time belt
     
  9. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,622
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    umm valve springs dont get torqued at all. wtf are you talking about? they are held on the valve by little valve keepers.
     
  10. myah

    myah Neu Impact Performance

    Messages:
    226
    Likes Received:
    1
    Joined:
    Jul 21, 2006
    Location:
    ks
    ok shit my bad i was looking at new valves when i wrote this shit my bad i said valve springs fawk
     
  11. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    aight, Im gonna drain the oil, refill it back up then do a compression test(again) then im going to get my valve adjusted. If that doesn't work...eh whatever. Let's see what happens.
     
  12. FlyBMXer4130

    FlyBMXer4130 Sh1tAssIntegras

    Messages:
    6
    Likes Received:
    0
    Joined:
    Oct 23, 2006
    Location:
    New Orleans "little mexico"
    I just recently had the exact same problem with my '91 Integra, no clue on what it was, at first I changed distributor/spark plugs and it ran better for a week or so, then while driving one day on interstate 70mph, let off clutch to coast and engine died, would turn back over after a minute of sitting, smelled & heard something under hood, timing belt was being torn somehow but still had tension... when I replaced the plug wires, it started up didn't idle had to gas it, and leaked all oil out immediately when turning over... been having no clue where to go from there except B18C1 it... 'til the $ comes in what to do???
     
  13. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD
    Your compression readings tell you nothing about the condition of your bearings. Don't waste your time again. It's definitely a rod bearing that has been spun. Like Ian said, time for a rebuild. This is what happens when you run out of oil.
     
  14. ep3kid510

    ep3kid510 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Oct 10, 2006
    yeah thanks bro, but you think buying a head will fix it?
     
  15. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD
    No. The problem is your connecting rod bearing(s) in the lower end. You can't just replace them. At this point, you'll need to take the block to a good machine shop and have them assess the situation and determine the next steps. It will depend on the severity of the damage.
     
Verification:
Draft saved Draft deleted

Share This Page