1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

96 auto h22a setup in my accord runs sluggish

Discussion in 'Accord' started by Seducer, Feb 22, 2007.

  1. Seducer

    Seducer Junior Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Feb 16, 2004
    I have a 96 Accord, that I had an engine swap performed on. I still have the original ECU as well as the one that came with it. She is extremely sluggish in first gear, like I'm accelerating underwater. Once I get to 4500 RPMS, she takes off like a rocket. Does this sound like a tuning issue? I also learned that the knock sensor is missing from the swapped engine, which is why my check engine light has always been on. Could a sensor like this create such a sluggish feel? Could a good tune job eliminate this?

    Lastly, anyone know any good swap shops in either VA or MD? Actually any within' 300 miles would be good... so that's about from New York to NC....
     
  2. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    If you have any codes thrown up that could be why its running slow, in limp mode. The knock sensor is pretty vital and needs to be hooked up, that should take care of your problem most likely. Reset the ecu after you install one.
     
  3. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    Also make sure you are using the ecu from the h22.
     
  4. Seducer

    Seducer Junior Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Feb 16, 2004
    So this limp mode. Would it just do that in first gear, up to 4500 rpms? I will definately get a knock sensor off of eBay. I heard about limp mode, but thought it would hinder the engine throughout the full powerband...not just the first 4.5k
    :(
     
  5. Nickg4c

    Nickg4c Member

    Messages:
    127
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Gilbert, Az
    In Limp mode you shouldnt be able to rev as high, but yeah it would be power loss throughout the entire powerband. Either way any check engine light will cause you to lose power, I think. By what you say you really need to get it tuned, as well. I remember my car ran terrible for awhile before I tuned it, same kinda thing once it got up high it was fine but it stumbled like crazy down low.
     
  6. Seducer

    Seducer Junior Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Feb 16, 2004
    Thanks to all

    That's what's up guys. I appreciate that. I'm on eBay now bidding on a knock sensor, and once I get that, I'll install it, and have the car tuned. Thanks again :)
     
  7. Seducer

    Seducer Junior Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Feb 16, 2004
    Forgot to say, I'll post results and pics after that....
     
  8. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    I was just wondering if there were any mods to the h22. Like cams or whatever. Because with the right ecu the car should run great with factory everything. Tuning may not be worth the money if you havent done much for mods.
     
Verification:
Draft saved Draft deleted

Share This Page