1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

97 Civic HX electrical problem

Discussion in 'General Tech and Maintenance' started by boatmobile, Apr 14, 2007.

  1. boatmobile

    boatmobile New Member

    Likes Received:
    Apr 14, 2007
    Hey guys,

    New to the forum and plenty of useful information here. I figure if anyone knows one of you will.

    I have a stock 97 civic HX and the battery went dry on me.

    I was diriving at highway speed and all of a sudden, I lost power. the tac went to 0 and the temp guage started moving with the revs. I would let it idle and the tac would come back and the temp guage would level off but as soon as I put a load on it, it would do the same thing.

    Then all of a sudden something shorted and the horn started blowing, the stock radio is feedback with the display fully loaded wityh all characters (will not turn off)

    The directional lights went, the 4 ways went, the low beams went

    high beams, reverse lights are ok

    I hooked up a new battery and car runs fine (ran fine without a battery as well) but I cannot find the electrical problem.

    I pulled the dash out but there are no burnt wires, all fuses are fine under hood and in dash. I took it around the block to troubleshoot and got about 50 yds and horn starts blasting but didn't lose power. stoped immediately and horn stopped when revs came back down.

    I smell a burnt wire in the dash or residual odor of one

    Any ideas?


  2. eg6sir

    eg6sir Supa Mod Moderator VIP

    Likes Received:
    Aug 17, 2005
    661 BK CA
    wow.. thats alot of shit to go wrong.. i suck at wiring or i'd try and help you out
Draft saved Draft deleted

Share This Page