1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

98 Civic "HX" B18B1 LS wiring problem

Discussion in 'HYBRID -> EG-EK / DC' started by Sil VurFoX, May 25, 2004.

  1. Sil VurFoX

    Sil VurFoX Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    May 21, 2004
    Please help..
    I'm throwing engine code P0135 Primary Heated 02 Sensor circuit fault , P0113 Intake Air Temp. sensor circuit High, and P1337 Crankshaft Fluctuation Sensor no signal.

    Here is what I have..
    1998 Civic "HX" stock wiring harness.. the only model that has the 7 wire o2 sensor
    Engine B18B1 I believe is a 94-97 model.. doesn't have the sensor on the crank.
    ECU 37820-P75-AO3 which I belive is a late 97 or possibly early 98 computer?

    I tried to wire a 4 wire Bosch replacement 02 sensor but I've failed. What do I need to do in order to kill this engine code? Purchase a "EX" wiring harness?

    If I remember correctly the 02 sensor is tied together some how with the IAT fault code that I'm throwing. I'm hoping once I fix the o2 it will cancel the IAT.

    Do I need to buy a 1996 model ECU to cancel out the P1337 code?

    With the engine throwing these codes, the local dyno ran it and I have 230whp 200lb of torque. But I need to sort these codes before I can go any further.. any thoughts would be appreciated.
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    what ecu are you running?
     
  3. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003

    230 hp is it built?
     
  4. Sil VurFoX

    Sil VurFoX Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    May 21, 2004
    Pissedoffsol:
    This is the serial number on the ECU is 37820-P75-AO3-980-204125L6 which I belive is a late 97 or possibly early 98 computer out of an Integra "LS". I've tried to research the computers and I belive the 1996 computer 37820-P75-AO2-980-103929 computer should eliminate the code, because the CFS sensor was on 1998 on up TEGs. What do you recommend? Is my thinking correct on the "EX" wiring harness changeover? I've read a ton of your postings and hope you can point me in the right direction. Thanks..

    SpodaB1:
    The engine is completely stock.. 230whp / 200lb of torque @ 7lb of boost.
    I have a 96 "LS" engine that is being sleeved, Wiseco Pistons, Carrillo Rods.. and my new Garrett turbo..should support 450whp.. but I want my electronics figured out before I go any further.
     
  5. Sil VurFoX

    Sil VurFoX Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    May 21, 2004
    Pissedoffsol... what ECU should I be using, and what wiring harness would you suggest to fix my problem? Thanks..
     
  6. Sil VurFoX

    Sil VurFoX Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    May 21, 2004
    Well figured this thing out.. I put a 96 "DX" engine harness in my "HX" and I burned the old one for the hell of it.. My engine is OBD1 so I bought the skunk 2 jumper harness and a P75 OBD1 ECU with the Hondata chip.. going to the dyno in two weeks..
     
  7. driverunknown

    driverunknown Senior Member

    Messages:
    1,474
    Likes Received:
    1
    Joined:
    Feb 11, 2004
    lol you probably could have sold the harness.
     
Verification:
Draft saved Draft deleted

Share This Page