1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

99 si not revving past vtec 5600

Discussion in 'Civic and del Sol - EG and EK' started by briansteffen, Dec 17, 2009.

  1. briansteffen

    briansteffen New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Nov 26, 2006
    Location:
    rochester, mn
    so what happened is i was installing a new cap and rotor and didn't unhook the battery and it blew the fuse for the coil. I replaced the fuse and now the car feels like there is no spark at about 5500rpms. could i have shorted out the icm or the pick up for the coil inside the dist. I am running a P30 with a conversion harness and msd ignition box and external msd coil.
     
  2. pooksy64

    pooksy64 RidetilldeathdousparT

    Messages:
    148
    Likes Received:
    1
    Joined:
    Jul 18, 2008
    Location:
    HOUSTON tX
    try going back to the stock set up and go frm there so u can test the icm&coil. rule out the msd ign portion see how the stock set up will run the motor
     
  3. briansteffen

    briansteffen New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Nov 26, 2006
    Location:
    rochester, mn
    could i use a stock coil and cap out of my ls motor? i tested my coil and it is within specs.
     
  4. briansteffen

    briansteffen New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Nov 26, 2006
    Location:
    rochester, mn
    fixed a wire was getting pinched when i tightend down the cap.
     
Verification:
Draft saved Draft deleted

Share This Page