1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Few Probs?

Discussion in 'General Tech and Maintenance' started by cnycivic, Apr 27, 2003.

  1. cnycivic

    cnycivic Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 17, 2003
    alright first off i have a 2000 civic dx with a 2000 ctr motor .. just got it done today ... or so i thought ... first prob .. it idles at 1500 then goes to 2000 then to 1500 over and over again ... next problem ... i have a 99 si ecu and the rev limiter kicks on at 6400 rpm ... WTF is happening ... ok next problem check engine light is on ... seems to be throwing a code 14??? what could it be ??? also my car is overheating .. all the hoses are good and i have a radiator ... so i dunno whats up ... and finally the shift linkage is realy wobbly ... when i put it in any gear it just flops around ... it stays in gear but i can move it all around like its in neutral ...
     
  2. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    Sounds like your wiring is fucked. Second of all, why wouldn't you just get a 2000 CTR ECU?
     
  3. cnycivic

    cnycivic Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 17, 2003
    well i bought the engine and i am using the stock wireing harness so the wires are good i believe .... but the ecu they gave me was a mistake then handed me an obd2 ecu and i have obd2b i believe so any other ideaz
     
Verification:
Draft saved Draft deleted

Share This Page