1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AC compressor getting no power

Discussion in 'Civic and CRX - EF' started by fixed4 life, Jul 2, 2012.

  1. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    I have a 90 Si, my ac compressor is not getting any power. I have hard wired it and it will kick on. Is there a relay or fuse somewhere that would cause it not to work? Could the ac button on the climate control be bad? Any help would be appriciated. I live in TX and its HOT!
     
  2. dc4dude

    dc4dude Member

    Messages:
    904
    Likes Received:
    17
    Joined:
    Aug 12, 2008
    Location:
    chicago, il
    short the switch terminal on the high side... see if that is getting power... sometimes the switch will go bad... also, if you dont have enough freon (because of a leak) it will also not go on... many different variables with the a/c dude.
     
  3. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    Thanks, i was messing with it earlier and it needed freon. It started working as soon as i filled it.
     
  4. dc4dude

    dc4dude Member

    Messages:
    904
    Likes Received:
    17
    Joined:
    Aug 12, 2008
    Location:
    chicago, il
    So that means you have a leak somewhere... Its is a sealed system, just like the brake system...
     
Verification:
Draft saved Draft deleted

Share This Page