1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

anyone had arp rod bolts snap

Discussion in 'Engine Building' started by AcuraTer, Apr 18, 2007.

  1. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    I was putting the pistons in my ls vtec when i went to torque the arp rod bolts and 1 of the bolts snaped at 25 lbs. these bolts are needed to make ls vtec stronger.but that bolt snaped like butter.anyone ever hear of any problems with these bolts.also will the pr3 pistons work well in my ls vtec,b18 block ,b16 head and cams all stock
    thanks
     
  2. bistec

    bistec Project EH23

    Messages:
    335
    Likes Received:
    1
    Joined:
    Dec 6, 2006
    Wow!
     
  3. hondacrxb16vtec

    hondacrxb16vtec New Member

    Messages:
    241
    Likes Received:
    2
    Joined:
    Sep 13, 2006
    Location:
    lemoore, califoria
    you broke a arp bolt!!! damn that's weird. yes the pr3 pistons will be fine on your build. if you want more power go with some ctr's.
     
  4. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    Heres a couple of pics of the 8 mm arp rod bolt that snapped.

    [​IMG]

    [​IMG]

    [​IMG]
     
  5. hondacrxb16vtec

    hondacrxb16vtec New Member

    Messages:
    241
    Likes Received:
    2
    Joined:
    Sep 13, 2006
    Location:
    lemoore, califoria
  6. killercannible

    killercannible Senior Member

    Messages:
    633
    Likes Received:
    2
    Joined:
    Jul 17, 2005
    Probably a bad batch of metal, send it to arp and they will probably send you a new one.
     
  7. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    yes i hope it was bad batch.lol getting a new set tomorow
    as for my set up i got a b18 block with 81.50mm bore ,pr3 pistons ,b16 head ,valvetrain,cams chipped ecu with gsr tranny. a month ago i has a b16 with a ls tranny in my da 92 teg. big upgrade
     
  8. JDM_EK9R

    JDM_EK9R all motor

    Messages:
    81
    Likes Received:
    1
    Joined:
    Nov 4, 2006
    Location:
    central, NJ
    that sucks ... what rods are you using?
     
  9. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    I am using ls rods but they are shot peened.
     
  10. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    personally i'd send all of them back and ask for a completely new set
     
  11. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    my new set will be hear tomorow, I hear you ,I don't trust the rest of that batch.lol
    hopefully that was 1 in a million that it snaped.lol
     
  12. civicious

    civicious FüK-VTEC VIP

    Messages:
    9,855
    Likes Received:
    629
    Joined:
    Jun 15, 2003
    Location:
    Houston, TX
    crossthreaded perhaps?
     
  13. AcuraTer

    AcuraTer New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Apr 18, 2007
    yes that's possible
     
  14. intenseneal

    intenseneal New Member

    Messages:
    257
    Likes Received:
    1
    Joined:
    Apr 10, 2009
    I know this tread is really old but I am getting a set of SRP rod bots for my LS Vtec. I hope this was a bad bolt. I used ARP head bolts for my 87 Supra Turbo and they worked great.
     
  15. civicious

    civicious FüK-VTEC VIP

    Messages:
    9,855
    Likes Received:
    629
    Joined:
    Jun 15, 2003
    Location:
    Houston, TX
  16. intenseneal

    intenseneal New Member

    Messages:
    257
    Likes Received:
    1
    Joined:
    Apr 10, 2009
Verification:
Draft saved Draft deleted

Share This Page