1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B16 CRX hesitation

Discussion in 'HYBRID -> ED-EF / DA' started by Reckone, Aug 4, 2007.

  1. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    Just put a B16a into my 91 si crx a week ago. The motor was sitting a while in Japan. I got it over here to through in my rex. The swap went easy. It runs good, no check engine light, idles smooth.

    My problem is: When cruising at around 4 grand, it hesitates when accelerating until you hit v-tec. Its almost like a miss fire but not quite. I have already done plugs, wires, rotor, cap, coil, ran seafoam through it, and injector cleaner. I also swapped out the TPS sensor today but no difference. Any ideas?
     
  2. Italix

    Italix New Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    Jul 20, 2007
    what cel is it throwing? could be knock sensor or map.....
     
  3. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    Its not throughing a cel. Swapped out the map and tps already. No change.
     
  4. Italix

    Italix New Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    Jul 20, 2007
    the only thing that comes to my mind is timing. What's it set at?
     
  5. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    I haven't thoched the timing since it was pulled in Japan. I haven't even taking the dizzy off it.
     
  6. b16crxsi

    b16crxsi team ugly

    Messages:
    24
    Likes Received:
    0
    Joined:
    Aug 31, 2006
    Location:
    sarnia, ontario canada
    my car had similar symtoms but it turned out to be one of the O2 sensors. no light on the dash, but the red led was lit up. 1 flash. it cures my problem tho.
     
  7. Carl425

    Carl425 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Apr 30, 2007
    Dude, you have the EXACT same problem as me and I haven't figured mine out yet either. If you do, PLEASE let me know, its driving me NUTS! I got my motor and trans from Hong Kong and put the setup in a '89 EDM Rex. It runs and idles great but I get that same hesitation you do and it only happens when its hot too. When it's cold its not there. Mine will usually come out of it just prior to Vtec say, around 4K give or take a hundred RPM.
     
  8. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    I unpluged the one O2 sensor (white plug). It seems to have cleared up. I am going to replace it tomorrow. Will let you know how it runs. But as of now I believe that was the problem. I started with the green O2, but it was still there a bit.

    It has no check engine light even with the O2 unplugged.
     
  9. Carl425

    Carl425 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Apr 30, 2007
    Cool. Please do let me know. If it's something that simple I'll be happy!
     
  10. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    well its always advisable to change the timing belt before putting the motor in the car..
     
  11. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    man, i've got the same problem too!
    except mine is all of the time it seems to miss at everything but WOT, but less noticable at low rpm's. and i get a cel on long deceleration in-gear for o2b after it's warm. i've replaced both o2 sensors, as well as my valve cover/spark tube seals/gaskets, and cleaned the plugs. whatever it is is causing one pair of cylinders(2&3) to lean out, and I don't know what it is. i've tried more things too, but yeah. i'm putting in new ngk wires today also. never know. they're jdm stock ones from the import.
    let us know what it was to fix it, and i'll try that. i still have to replace the tps and check timing. but other than that, i'm probably gonna take the head off and check valves, etc..
    so frustrating!
    i'd be interested to know what fixes your guys' problems.
    carl425, try making sure you have the two o2's not switched around. assuming you have the obd0 b16a. that'll cause that problem.
    ps. i'm not threadjacking. just ignore me. i'm here to observe.
     
    Last edited: Aug 7, 2007
  12. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    The motor has 25k miles on it. Theres no need to change it at this point.
     
  13. smokey345

    smokey345 SwAp CrAzY

    Messages:
    47
    Likes Received:
    0
    Joined:
    Mar 17, 2007
    Check your compression. For all you know that headgasket is going and it doesen't matter how many miles are on the motor. It matters how long the motor has been sitting around as well.
     
  14. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    lol. yeah. ditto. i just found out my headgaskets leaking into the manifold. and i'm putting money on it causing my o2 code and my drivability issues. so, yeah, like he said. look for leaks and check your compression. and make sure there's not coolant in your oil, and no oil in your coolant.
     
  15. Reckone

    Reckone EF aholic

    Messages:
    190
    Likes Received:
    0
    Joined:
    Jan 27, 2007
    Location:
    Albany, NY
    It was the O2 sensor.
     
  16. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    that's good to hear;)
     
Verification:
Draft saved Draft deleted

Share This Page