1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16 help!

Discussion in 'Civic and del Sol - EG and EK' started by 94civicturbo, Nov 2, 2010.

  1. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    well my b16a2 has been acting weird in my eg today, ill be driving and itll just seem like it died, it idles really low and wont rev or anything, my temp gauge has been a little higher than normal too, but i shut it off for about 10 seconds then i start it back up and runs fine for a few minutes then it does it again, any ideas?

    i stopped and let pressure off the radiator and it ran good for a little while then it started again, HELP PLEASE!
     
  2. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    anyone please? i've heard maybe the IACV or the fuel pump?
     
  3. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    i hate bumping my own threads but please help guys i need this fixed, this car is my daily and it is a real pain to drive with it doing this, on my 10-15 minute drive home tonight it died 5 times
     
  4. johnOBD

    johnOBD New Member

    Messages:
    70
    Likes Received:
    0
    Joined:
    Aug 24, 2010
    could be few things man. 1st thing when it dieds next time turn off ignition , turn back on ign LISTEN !! can you here fuel pump run?? if you can hear it . check for spark , do fault code.
     
  5. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    ill try it, i want to check my fuel pump with a multimeter, anybody know the best way to do it?

    i replaced the ICM in the dizzy and it still does it pretty badly
     
  6. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,411
    Likes Received:
    148
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Put key to on position but do not turn over the engine. Once the key turns to on....listen for your main relay to do a series of clicks under the dash by the hood release handle. And you can hear the fuel pump turn on while the main relay clicks on.

    I think its something with your coolant system. You wrote of your temp going up. Fan turning on? Clog in the system? Air bubble? Thermo opening up? Flush it out and burp it once you fill it back up. Check for fan to turn on once its nice and warm.
     
  7. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    i was thinking that too, the fan does turn on, i was thinking the coolant temp sensor, ive read that can be the cause, and it has a brand new thermostat in it
     
  8. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,411
    Likes Received:
    148
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I'd flush it all out first. Its a little messy but cheap and easy
     
  9. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    yeah i think i will and see if it helps
     
  10. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    i got it fixed, flushed it and put a different t-stat in and it runs perfect now :)
     
  11. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,411
    Likes Received:
    148
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Nice. It must have been clogged. Bad Thermo are suppose to stay wide open when they go bad
     
  12. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    yeah idk i think the one in it now is staying open all the time but oh well the car runs at least
     
  13. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,411
    Likes Received:
    148
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    you'll know when you drive on a cool night and the temp gauge falls to cold running temps b/c its got cold wind cooling the radiator big time and thermo never closes
     
  14. 94civicturbo

    94civicturbo New Member

    Messages:
    1,477
    Likes Received:
    23
    Joined:
    Dec 11, 2008
    Location:
    Liberty, IN
    its cool all the time now lol, but since ive had it the temp gauge has rarely moved
     
  15. fakespooneg

    fakespooneg New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 23, 2011
    thanks for you posting this cause i was having the same problems. and cafrog youe awesome bro
     
  16. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    389
    Joined:
    Apr 16, 2006
Verification:
Draft saved Draft deleted

Share This Page