1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16 idle at 1250rpm

Discussion in 'HYBRID -> ED-EF / DA' started by b16ingp, Sep 23, 2003.

  1. b16ingp

    b16ingp Junior Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Sep 22, 2003
    When I start my b16 obd-0 car it idles at close to 2000rpm cold. But when warmed up comes down to around 1250. Still kind of high isnt it?
    I read somewhere that it should idle at 750rpm. What can I do to adjust this?
    Is it not pcm controlled? As far as I know the ecu has not been chipped or messed with.
     
  2. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    It's controlled by the IAC valve... are you getting a Check Engine light? Since yourcar is obd-o it should have a LED on the ECU. The IAC valve is on the back of the Intake Manifold this controls the amount of air that goes into the engine at start up, and also throughout the operation of the engine. If this is messed up and doesnt work it is usually the main cause fr the engine to run improperly as far as the idle goes I mean. So check Vacuum lines, along with the electrical connector on the back of the IAC, also check the bolts to make sure they are tight, if they are loose go a head and take off hte IAC to check the O-ring between the IAC and IM, if it is broken or worn replace (not sure if you can buy a new one), then tighten the IAC back on. Hope this helped
     
  3. b16ingp

    b16ingp Junior Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Sep 22, 2003
    Actually I had eratic idle for the longest time when warm, i tracked it down to the iac being carboned up. I cleaned it, but do not recall if there was an o-ring on it. Perhaps that is my problem, all the vaccum lines and eletrical connectors are fine.
     
  4. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Check out that seal you mentioned, mine idles at 750.
     
  5. kingwilly

    kingwilly Senior Member

    Messages:
    349
    Likes Received:
    0
    Joined:
    Mar 10, 2003
    Location:
    arizona
    check or replace your intake manifold/throttle body seals
     
  6. Uppertorso

    Uppertorso Senior Member

    Messages:
    106
    Likes Received:
    0
    Joined:
    Apr 8, 2003
    Location:
    Winnipeg, Manitoba
    i have also heard that a map sensor from a 90-93 integra will help stablize and smooth out idle, but to me your problems sounds like it is with the IAC, check the reference area, there is a procedure for setting up the idle.
     
Verification:
Draft saved Draft deleted

Share This Page