1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16 swap problems

Discussion in 'HYBRID -> ED-EF / DA' started by 90dxb16, Jun 22, 2004.

  1. 90dxb16

    90dxb16 Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jun 22, 2004
    well hears the problem, I have a 90 dx 4 door, that i just put in a b16, the motor has the hasport converision harness I started the motor and revs high and it started to overheat I have new waterpump and t stat it seemed like water wasent even circulating through the motor, then realized did not have ect senser so put one on and still doing the same thing. next problem when the motor was running it was showing a code 4 (crank angle senser) if I'm not wrong and a code 7 tps senser so I reset the ecu and it would not start. While the motor was cranking the led light would stay on. Is that bad ecu. Does any one know how to adjust tps. Any help would be great.
     
  2. StarBellieAngel

    StarBellieAngel Senior Member

    Messages:
    1,679
    Likes Received:
    0
    Joined:
    Jan 20, 2003
    Location:
    San Jose, CA
    if your question is how to adjust the TPS you just turn it a little either way and reset the ecu to see if the CEL is gone.

    the overheating is probably (well, i think it IS) a whole different issue.

    we had the same type of thing happen with my DA when we did a B16 swap. Check to make sure your cooling fan comes on. if you're not getting coolant pumped thru, you might want to check your water pump. make sure it's brand new, and not just a 'brand new rebuilt' one. we replaced the thermostat, the ect switch, and just had to get an adjustable fan switch to flip it on for us when we needed it... since we don't know why the fan wouldn't come on anymore.

    jdm b16's run a lot hotter than the b18 we had... so, it's probably got a lot more heat to deal with. anyway, check and make sure your fan works. :)
     
Verification:
Draft saved Draft deleted

Share This Page