1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B16 With D16 Harnest Problem

Discussion in 'ECU's, Electronics, and Tuning' started by ricerocket93, Apr 3, 2003.

  1. ricerocket93

    ricerocket93 Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 3, 2003
    :worthy: I got one 93 jdm b16 in my 93 hb si and the motor is conected to the d16 harnest.The b16 ecu keeps sending me 2 check engine.o2 and knock.Can somebody help me?
     
  2. jhfarmer

    jhfarmer New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 6, 2009
    possibly need to wire in knock sensor and second O2

    When you installed the b16 motor, did you wire in a second O2 sensor and a knock sensor? The b-series motor runs two O2 sensors and a knock sensor that won't be on the d-series engine. I've just finished a b16a swap into an 89 Crx (Auto to manual trans conversion), when we wired in vtec, we also had to wire in and install a second O2 and wire the knock sensor to the ecu. I'm using a 91 d16 harness, so you should be in the same position, unless you've already wired those up.
     
  3. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Im in the middle of the same swap (and I'm about to get a D16 wiring harness from a junkyard)

    I have the motor in my garage (B16) but I only see one O2 sensor. Isn't there only one on the down pipe of the exhaust manifold?? Knock sensor goes to D3 on the ECU and I think I got that under control but now I see that someone claims there to be TWO O2 sensors?????

    Ricerrocket93: If I'm right and there's only one O2 sensor...maybe yours is bad...?? Replace and reset the ECU....if I'm right but if I'm wrong...can someone explain and give the location of the second O2 sensor?

    I took the wiring harness off the JDM B16 motor today (b/c its reversed) and only had one O2 sensor unless its located somewhere else besides the exhaust manifold and I simply figured it for another sensor.
     
  4. oyy0

    oyy0 Sleepy...

    Messages:
    86
    Likes Received:
    3
    Joined:
    Jan 26, 2008
    theres only one O2 sensor. your O2 sensor might just have gone bad and you probably did wire your knock sensor in right.
    did you do it directly to the ECU or shock tower?
     
  5. oyy0

    oyy0 Sleepy...

    Messages:
    86
    Likes Received:
    3
    Joined:
    Jan 26, 2008
    the knock sensor wiring probably needs fixing or cleaning... a lot of people do shoddy work on this type of wiring cause they don't know any better.
     
  6. oyy0

    oyy0 Sleepy...

    Messages:
    86
    Likes Received:
    3
    Joined:
    Jan 26, 2008
    also, you can check to make sure the wires on the O2 sensor didnt get mixed up when they were lengthened.
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I JUST finished my swap in an EG si with a JDM B16A Saturday. I got the D16Z6 (not just any D-series harness..92-95 si, ex, vx or ANY '92 civic harness) I have my pics up on this site and you can see where I extended to the VTEC solenoid/oil pressure. You're right about the knock sensor into D3 but make sure you get a pin out of another ECU plug (two sizes and D3 is a smaller one). I used the pins out of the engine bay plug on a shock tower and it was too big (it was all I could find in town). I had to eat some plastic away with a small drill bit and massage the pin into position (wasn't easy and took me a good hour). If you can find the pins new....go for it but I had a hard time. I suggest going to a recycler of Hondas and get the pins you need and leave the wire long so you can use a barrel connector and run your knock sensor through the firewall.

    Some people may have other alternatives to plugging the line into D3 (like a chipped p28 instead of the p30) but that cost more money and IMO needs to be tuned....which is even more money. Or some may soder the line but I'm not confident in my abilities to soder so I made a pin insert work.

    I have only ONE O2 sensor and I had to extend it off the engine harness to make it go all the way to the downpipe (I've heard some OBD1 engines did have two O2 sensors but I dont think B16A did). I've seen another set up on an EG hatch where the O2 sensor wire was way longer and it made it up to under the dizzy where the stock plug rested (didn't need extension) but I had to extend mine. Liek someone else mentioned, you can try to clean it and if that don't work, get a four wire O2 from a recycler or friend b/c new ones are around $250 if its OEM

    Link to some of my pictures

    http://hondaswap.com/hybrid-eg-ek-dc/my-new-swap-eg-si-b16-286581/
     
Verification:
Draft saved Draft deleted

Share This Page