1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B16A Gauge Questions

Discussion in 'HYBRID -> EG-EK / DC' started by EG6Civic83, Sep 1, 2006.

  1. EG6Civic83

    EG6Civic83 New Member

    Messages:
    118
    Likes Received:
    0
    Joined:
    Aug 12, 2006
    I am not sure if this is classified as a swap question but since the motor is still waiting to be put in my car and I am having trouble with some wiring I thought this was the appropriate place to put this question.

    Okay so I am getting ready to put my B16A SiR II motor in my 92 Si Hatch and I needed to know how to hook up my mechanical oil pressure and water temperature gauges. On my stock D16Z6 there are 2 water temperature sending units, 1 on the inlet for the upper radiator hose and 1 on the inlet for the lower radiator hose. Problem is that when I unplugged the sensor for the upper radiator hose the check engine light came on and I got some erratic idle. I don't think I have a coupling for the lower radiator sending unit (it's like 22mm).

    Now I know I said I want to put these things on my B16A. I am just worried that I am going to run into the same problem with the B16 upper sensor (CE Light and erratic idle). What do I need to do.

    As far as the oil I was just wondering where the sending unit is for it and also how to hook it up. Thanks for any help.

    I also need to know which wire on my O2 sensor for the B16 is the signal wire for my Air/Fuel Gauge. My D16Z6 has 4 wires. 2 wires are black so I am assuming those are the ground wires. One is green and the other is white. Which one is the signal wire? Also, is the B16 the same set up and if so which color wire is the signal for that O2 sensor.
     
    Last edited: Sep 1, 2006
Verification:
Draft saved Draft deleted

Share This Page