1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16a problem

Discussion in 'Engine Building' started by ls vtec teg, May 29, 2011.

  1. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    hi



    I have b16a ls tranny

    vtec start ok but after 6500 rpm

    its dead the acclereation very very slow even in 1 and 2 gear and have some white smoke

    so what the problem ?
     
  2. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    Are you throwing a CEL? White smoke generally means burning oil. Does it smoke at idle and worsen when accelerating?
     
  3. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    no , no only smocking at high rpm
     
  4. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    what ecu are you running?
     
  5. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    Also make sure you have enough oil in your engine. Maybe lacking oil pressure causing vtec to not work properly?
     
  6. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    b16 ecu 8500 red line
     
  7. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    If your oil level is good and you're building enough oil pressure, it almost sounds to me like you're having ignition issues.
     
  8. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    yeh I think there are little leak but that the mean problem that make the car very slow?

    even my old b18b was much faster I think to buy b18b again and throw it on
     
  9. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    Check your oil level and make sure it's at the full mark on the dipstick. Lacking the right amount of oil will cause vtec to not engage due to there not being enough oil pressure. If you're near your car, this should only take a minute or two to check.
     
  10. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    ok I will check it tomorow and check the ecu too and tell you

    thanks
     
  11. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    No problem. Let us know if you have any other questions.
     
  12. josh_crewdson@y

    josh_crewdson@y New Member

    Messages:
    438
    Likes Received:
    4
    Joined:
    Dec 5, 2007
    Location:
    nova
    blue smoke is oil.
    white is coolant, if its running out of power and starting to miss at higher rpms, you probably popped the hg. i've had it happen.
     
  13. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    so what should I do to fix this ?
     
  14. BoosteDa

    BoosteDa New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 9, 2011
    Check all your basic fluids such as oil and coolant and let us know what it's looking like.
     
  15. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
  16. josh_crewdson@y

    josh_crewdson@y New Member

    Messages:
    438
    Likes Received:
    4
    Joined:
    Dec 5, 2007
    Location:
    nova
    do a compression leakdown test. if you are losing coolant, its probably your head gasket.
     
  17. ls vtec teg

    ls vtec teg New Member

    Messages:
    72
    Likes Received:
    0
    Joined:
    Feb 24, 2010
    I take it to garage

    the guy side there are problem in piston so I must change the block

    I see thay not worth it so I will put b20b on it

    I found one but there are two kind one 146 hp and other 126

    how can I know if its 146 hp ?
     
  18. Khabbs

    Khabbs New Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    May 17, 2011
    Location:
    Beacon NY
    agreed , sounds like you have a cracked head or blown head gasket
     
Verification:
Draft saved Draft deleted

Share This Page