1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B16a Swap Problems / Need Help

Discussion in 'HYBRID -> EG-EK / DC' started by magnum000, Feb 23, 2003.

  1. magnum000

    magnum000 Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Feb 23, 2003
    Just got the B16 into my 1990 CRX Si. Few problems, First I ordered an
    LSD trans with this motor and my speedo cable does not hook up, it appears
    to be an electrical speedo??? Is this right?? Will I be able to use my
    existing speedo and cable?? there is a plug on what appears to be a speedo
    hook-up but my cable is to short anyone have this problem?? Second I
    need correct axle for drivers side, what car will this be from?? Lastly
    the big off-white multi-pin connector is different from the connector on
    the car side can I just remove pins and match color to color?? thanks for
    any and all help.
     
  2. EFtypeR

    EFtypeR Junior Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Feb 9, 2003
    I just finished this swap. I had a B16 from an XSi. If that is the one you have(S1,YS1 tranny), you will need the pass side from a 90-93 Teg(usdm), and the drivers side from a 87-89 Teg(usdm). Sounds like you did the exact same thing I did. You should have swapped the CRX engine harness from the stock engine to the B16 when they were out. It is a royal(dirty too) pain in the ass, but you need to swap out the engine harnesses. Then you will need to run a few wires and do some work at the ECU and around the Dist and sensors. I am an electrical engineer, and I noticed the amount of work invovled trying to make the B16 harness work, and opted to use the original one. It's your choice, i know I made the easier descision. I didn't have the Si, I had a dx, so I had a lot more work. Mainly you will need to hook up for V-Tec, and change some wires at the ECU. Good luck...
     
  3. magnum000

    magnum000 Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Feb 23, 2003
    yea sounds like we had same swaps. withe the SI though all connectors are same except one, the one off-white near the master cylinder. If I can just match color for color on connector that would work too. Can I do that??? Oh also what about map sensor vacuum hookups. do you have pic or diagram??

    thanks
     
Verification:
Draft saved Draft deleted

Share This Page