1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16a swap problems

Discussion in 'Civic and CRX - EF' started by c0d0r12, Mar 16, 2007.

  1. c0d0r12

    c0d0r12 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Mar 16, 2007
    Alright guy's, im in a world of doo doo right now and I need some advice. I just had a b16a1 swapped into my 89 ef hatch and it's giving me some problems right now. I'm throwing these codes.

    1. iacv
    2.map

    I recently replaced that map sensor but the code is still there and the car is still running really REALLY rich. My idle chugs at best and the whole car skips at idle. And i'm pretty sure my pcv valve has clogged. This is what happened, tell me what you think.

    I was putting on a new tps which was bad also (problem solved) and when I tried to turn the car over to run it the thing died. It would turn over, crank and then die. Finally I remembered what happened to my buddy's 99 SI. So i pulled the hose leading to the intake manifold from the head and it ran fine, but with a high idle. After putting on a new pcv valve and re-running the hose, the problem still pursists. So as of right now, my car barely idles w/o feathering the gas, it gets around 10 miles to the gallon, and smokes really black.

    One last thing which is still stumping me, there's no vtec. Could that be from the two codes that i'm throwing? I have no clue...please help!
     
  2. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    There might be a problem with the wiring for the map and iacv. I would double check the wiring and make sure it is all good. If you are still using the firewall mounted map sensor make sure it is connected to a good vacumm source from the firewall. The car is probably if limp mode because of the thrown codes. It wont engage vtec untill the codes are cleared and everything is right.
     
Verification:
Draft saved Draft deleted

Share This Page