1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18 into EJ6 issues identify these sensors/plugs!

Discussion in 'HYBRID -> EG-EK / DC' started by arf4n, Apr 13, 2011.

  1. arf4n

    arf4n New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Nov 22, 2006
    Location:
    UK
    obd2b car and put in a b18, ive used the obd2b ek4 loom with a chipped p28.

    I thought this would all plug and play but i have some problems...

    The car seems like it doesnt want to run?! it barley idles and around 1.5k the revs bounce until i give it some more gas and will rev upto 4k

    its throwing up ecu codes;

    6 Engine coolant temperature
    10 Intake air temperature sensor
    14 Idle air control valve or bad ECM
    22 V-TEC pressure solenoid

    messed around / cleaned all of these and still the same?

    also i have these sensors/plugs left over..

    What is this plug for?

    [​IMG]
    [​IMG]

    which one is the engine coolant temp?

    [​IMG]

    Do i have two Intake air temperature sensors? one on inlet runner and one in induction pipe?

    [​IMG]
    [​IMG]

    I will be grateful for any help!
     
  2. EKB18B1

    EKB18B1 New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Mar 21, 2011
    hey man are u using d16y7 or y8 harness? also not sure why but we're kinda having the same issue...we swapped the b18b into my ek hatch and it threw few codes we worked them all out and now i got no cel but it wont rev over 3500... if u figure it out lmk
     
  3. EKB18B1

    EKB18B1 New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Mar 21, 2011
    oh also we just used iat on the intake not on the runners
     
Verification:
Draft saved Draft deleted

Share This Page