1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18a into crx hf question

Discussion in 'HYBRID -> ED-EF / DA' started by ryangt, Nov 19, 2005.

  1. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    sup fellas, ok im swapping a b18a1 into my 90 crx hf
    the interior harness where the wiring comes from the fuel pump to the fuse block in the inside of the car, theres a 4 pin white connector that looks like it should be for ignition or something because its pretty hefty wiring. i dont know what was supposed to go there since the wiring is all swapped into the car

    the harness comming to the fuse block goes to the fuse block, the main relay and then theres that connector mentioned above.

    if someoen has an HF and could take a peek and see what it plugs into id be eternally grateful.
    thnaks a ton in advance

    sorry for no pics or anything, if someone can post for me ill send you the pic.
     
  2. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    problem solved, i looked on a dx harness and found a relay there, i snatched it off and plugged it in my car viola it worked, the car fired and everything, it runs like ass tho, barely idles, smells like its running really rich.
    anyone have any suggestions as to how to get it healthy i tried to time it but im pretty hit or miss on that, ive adjusted the distributor bakc and forth trying to get it idling good, i adjusted the screw in the throttle body to no avail.
    Its throwing no codes
     
  3. Joka

    Joka Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    May 16, 2005
    Its prolly outta tune, Goto your local auto shop and have them tune it for ya.. And if thats to expensive you could always try it yourself but imo tuning = hell.
     
  4. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    well im not sure how to tune it but its not driveable, i can barely get it to do anything resembling an idle it just backpops alot and dies
     
  5. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    i have no power at the Idle air control valve and the fans wont kick on? any idea here folks?
     
  6. Citizen_Insane

    Citizen_Insane Senior Member

    Messages:
    3,698
    Likes Received:
    3
    Joined:
    Jul 24, 2003
    Location:
    Minneapolis
    Why'd you swap out the HF harness...theres nothing that you needed to change, the stock Hf harness would have plugged directly into the b18a with the exception of you having to add a Crank Position Sensor or something.
     
  7. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    it is a stock harness, a 89 harness the interior harness is the 89 as well, and it dosent all "just plug in" it fires but some other stuff needs to be lenghtened, and i still have no fans and its runnig like shit

    its popping really loud out of the exhaust, what the EFF is that about?
     
  8. illbred

    illbred Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Nov 26, 2005
    is probably adding alot of fuel thats why its poppin real loud... u sure everything is connected right, im doing the same swap round the middle of next week ill let u kno if my shit does the same thang....
     
  9. Joka

    Joka Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    May 16, 2005
    Couple things i can think off the top of my head.

    1.Idler pully does not spin (broke bB or sumthing) Which casues car to die.

    2. To much oil or old gas in the tank that was sitting awhile (stale) gas can cause this.

    3.Some of your wiring is messed up.

    4. Idler sensor is bad?
     
  10. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    how long would the gas have to sit for it to be nasty like that? Its been sitting for a little over a year, could it have gone stale in that amount of time? i thought it took a long time for that to happen. I pulled the fuel rail and the fuel looked clean and smelled right.
     
  11. Joka

    Joka Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    May 16, 2005
    oh yes, if it was sitting for over a year the gas has prolly gone bad and is nasty. This happend to me when i bought a parts car (it wouldnt start because of this) I put new gas and all fluids and it fired up.
     
  12. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    my list of stuff to check is growing, keep it comming guys, im trying it all.
    as far as i know, everythings hooked up right, its all pretty much plug n play with a few loose ends but nothign that should be controlling gas.
     
  13. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    ok some more crap.
    Theres a little single prong connector on the back of the blick that looks like it plugs into the harness with a big black boot over the connector on the harness. I touch that to the sensor and the fans kick on. They dont shut off tho, they stay on like its hard wired. Any ideas?
    Does anyone know what color the wires going to the thermostat housing temp sensor should be? Im trying to figure out if that plug and the tps got mixed up.
     
Verification:
Draft saved Draft deleted

Share This Page