1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18a problem

Discussion in 'Civic and CRX - EF' started by ctbmotorx, Sep 19, 2010.

  1. ctbmotorx

    ctbmotorx New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jun 6, 2010
    I have a 1990 b18a1 swapped into my crx that was already done when I bought it. It is all stock. Anyways today it started having major power loss like it did before I fixed the o2 sensor harness a month ago. It is hard to start, shuts off when i'm coming to a stop. There are vacuum hoses not connected and my purge solenoid is missing. Is it suppossed to be like that? Is it possible that it doesnt have a map sensor too. Anyway, i'm wondering how to fix all this if it is even worth fixing. I have dumped so much money into this just havent done the engine problems till now, so I dont really want to give up. Please help I need to be able to get this car running smoothly so I can drive it to work.
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Reconnect all your stuff first... if you're a human being with half your veins and arteries disconnected, you're not going to run too well either.
     
  3. ctbmotorx

    ctbmotorx New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jun 6, 2010
    Ok and if I need a new map sensor can I get one from an integra
     
  4. ctbmotorx

    ctbmotorx New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jun 6, 2010
    Or does it have to be from a crx
     
  5. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
  6. ctbmotorx

    ctbmotorx New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jun 6, 2010
Verification:
Draft saved Draft deleted

Share This Page