1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18a swap will only rev to 3500 rpms

Discussion in 'HYBRID -> ED-EF / DA' started by nwkdonblk, Jan 15, 2010.

  1. nwkdonblk

    nwkdonblk New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Sep 12, 2009
    Location:
    oakford il
    i swaped a b18a into a 90 hatch back finally got all the parts to get it driveable but , with the car in neutral sitting still can only get 3500 rpms out of the motor and when i try to move it wants to fall on its face it idles the way it should it does have a code 16 popping up havent got that one figured out :confused:
     
  2. isthisnameok4u

    isthisnameok4u New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Jan 7, 2010
    code 16 is fuel injectors

    You should check the 2 fuel injector wires you ran straight from the ecu to the injectoers. A1 on the ecu should have a BRN wire running to inj. #1. A5 on the ecu should have a Lt BLU wire running to inj. #3.

    #2 and #4 injectors are the ones already in your harness, RED to A3 and YEL to A7

    It is posible to mix these up and still get it to idle, but only two injectors are firing, or firing at the wrong time. Hope this helps man, I did a 90ls swap into a 89lx 4 door, it took awhile but I have a much better understanding of the wiring now because of my struggles.
     
  3. nwkdonblk

    nwkdonblk New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Sep 12, 2009
    Location:
    oakford il
    thank you i was messing with it yesterday had a nice day in IL, i cant remember which plug wire i took off but it never changed the sound of the engine or affect the idol so i put it back on then i took another one off and it did change bad thing is i dont know which ones they were will take my manual out with me today and check it out some more again thank you
     
  4. b18hatchman

    b18hatchman New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 30, 2009
    i had the same problem with mine it was the fuel injector resitor box check ur injectors first then check that i forgot how many ohms its suposed to pull but maybe find a budy that will let u borrow a good one to hook up or go buy one dont remember rite off what they cost hope this helps
     
  5. civichatch1988

    civichatch1988 Ef hatch

    Messages:
    257
    Likes Received:
    3
    Joined:
    Jan 4, 2010
    Location:
    Seattle
    I had same problem idles fine but falls flat on it's face did you switch the tps wires on the sensor? If not you need to it's the 2 outer wires so there's 3 wires total on the plug switch them 2 outer ones 1.2.3, 3 and 1 need to be switched should be a green wire and a yellow
     
Verification:
Draft saved Draft deleted

Share This Page