1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18a1 in 90 hatch idle problems

Discussion in 'HYBRID -> ED-EF / DA' started by fixed4 life, Mar 6, 2007.

  1. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    I just swapped a B18a1 into my 90 hatch. When i turn it on in the mornings it idles high 3000 rpms. After it warms up it idles up and down between 1000 and 2000 rpms i am using a 91 integra ecu. The ecu is not throwing any codes so unsure what it is i have checked my vaccum lines they seem to be ok. Any help would be appreciated.
     
  2. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    I would check out your idle air control valve. It is located on your intake manifold. I would take it off and make sure the screen on it is clean, and that it is functioning correctly.
     
  3. ef9davejdm

    ef9davejdm New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Mar 20, 2007
    Location:
    Norcal2Socal
    either throttle body is shot and is leaking air out enourmously or ur heating core is bad go have them checked out i had the same problem swapping a b18a1 a while ago but i had a bad Throttle body lawl...but pay someone to check it out or if you know enough you do it...
     
  4. fixed4 life

    fixed4 life New Member

    Messages:
    59
    Likes Received:
    1
    Joined:
    Oct 5, 2006
    Location:
    Haltom City TX
    I finally figured out the problem it was the PCV valve
     
Verification:
Draft saved Draft deleted

Share This Page