1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18a1 swap problems

Discussion in 'HYBRID -> ED-EF / DA' started by hatdude4, Oct 25, 2005.

  1. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    b18a1 in a civic dx. wiring was swapped to mpfi. car starts up and drives until i hit the gas hard then it is like it bogs down. has a pw0 ecu and only an exhaust manifold, no exhaust. ecu is throwing code for coolant temp sensor. any ideas???
     
  2. VTECPOWER

    VTECPOWER Senior Member

    Messages:
    1,683
    Likes Received:
    0
    Joined:
    Oct 6, 2003
    Location:
    Winchester, VA
    Fix your codes, and get the right ecu for your engine.
    Then come back.
    We will talk then.
     
  3. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    PW0 is a VTEC ECU - it is probably looking for VTEC, knock sensor, etc. and going into limp mode
     
  4. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    is pr4 the right ecu.
     
  5. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD
    Swap the outter wires on the TPS sensor plug. When you floor it, the computer thinks you're at fully closed throttle instead of WOT. And yes, the OBD0 pr4 ecu is the correct one for that motor.
     
  6. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    changed computer to the pr4. still throwing code for coolant temp sensor.
     
  7. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    i would check the wiring. if you can do a continuity test on it with a multimeter (long probe) then do that. If not just check and make sure its in one piece. If it is then replace the sensor. ECT will put you into limp mode for some reason...
     
  8. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    coolant temp sensor wasnt plugged in all the way. stopped throwing code for that now i can floor it and it will drive but when i get to 3000rpm the engine bogs down like there is a rev limiter at 3000
     
  9. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    anybody have any clues
     
  10. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    check your timing?
     
  11. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    timing is fine. as soon as the needle hits 3000rpm the car basically shuts down
     
  12. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    also need the vacuum diagram for a b18a into a 91 civic dx
     
  13. hatdude4

    hatdude4 Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Oct 25, 2005
    i think it is the map sensor.
     
Verification:
Draft saved Draft deleted

Share This Page