1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18b in eg hatch high idle when cold

Discussion in 'Civic and del Sol - EG and EK' started by stoopidb18eg, Apr 23, 2011.

  1. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    Hey again guys. Im hoping to get some help on why my car idles at 3k rpm when its cold? I posted another thread but i must have asked too many questions lol. This right now is my biggest concern. I have a 93 dx hatch that has a jdm b18b and gsr trans. This is my first swapped civic so i dont know what to look for. I cant seem to find any loose or unplugged wires anywhere and it almost looks like it came this way. Except 1 wire. It is ran all by its self and come from the wire harness on driver fire wall/ strut tower area all the way to the small prong on the starter. I mean it starts just fine everytime and dont think this has anything to do with my problem, just thought i would mention it. My warning lights all work but what ever is the problem is not making it throw a code. So basically when the car is at operating temp, it starts and idles fine, but if it sits a few hours and cools off , it starts and runs at 3k rpm and there is nothing i can do to make it idle down until it warms up. It takes any where from 3-5 minutes everytime. Im really hoping this is a common problem and someone can shed some light it for me. Thanks
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Probably your FITV (fast idle thermo valve) It plays a factor in the idle on cold starts.
     
  3. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    thanks man im gonna have to check on that. any idea where its at? im not the best mechanic but im also not a novice. I have worked at 3 different part stores in the past and this is something that dont sound familiar. Im hoping thats what it is.
     
  4. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Its on the OBD1 Throttle Body (mounted on the bottom of the TB). It has two coolant lines going to it......and thats it. There are ways to check/clean it if you take it off but the part isn't too expensive IMO. It has a plunger like mechanism in it and sometimes it can get stuck. It is suppose to be open and allow the engine to idle higher when the motor needs to warm up. Once the coolant gets hot enough (the lines gong through the FITV) the FITV plunger closes and IACV becomes the main controller of the idle.

    If you take it off and check it....the plunger may be too loose. Please read more into FITV cleaning and adjusting threads b/c you should know what you are looking for.

    You idle never "hunts" at all??? (up and down hunting for its right spot)
     
  5. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    someetimes after it warms up it will idle up and down but not all the time and when it does it dont fluxuate much. I looked into the forums and found out how to remove it and clean it and im sitting here now doing it. It didnt appear to be dirty the b18 come from hmo motors and was said to have less than 50k miles but i took it apart and cleaned it anyway. The only weird thing is it was on the side of the intake instead of under it. I also noticed there is a plug unplugged behind the engine that is exactly like the map and tps sensor but i cant find a place for it. i switched it around with the 2 it fit in but the car wouldnt run. I hope this was it im going out to put it back on.
     
  6. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I believe you just took off the IACV (between the IM and firewall). I have owned a JDM OBD1 swap and FITV is on the bottom of the TB (just lke USDM). FITV is mounted to the TB (on the bottom)
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL

    So there is an empty plug or no.....?? (sorry but I am a little confused by this whole quote above) I blieve the IACV is suppose to have an electrical plug that is like the IAT sensor and MAP sensor plugs. It also has two coolant lines coming from the bottom and its held on with two bolts. I believe the FITV is 3 10mm bolts and I know it doesn't have any electric connector at all.
     
    1 person likes this.
  8. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    I just got it done and now it idles at 2k instead of 3k when cold. Im sorry for the confusion I just happened to find that plug while in the process of removing the fitv. Its just a plug laying back there and it fits into the tps and map sensor but when in tps it wont start and in the map sensor it starts but engine light come right on. I took off the ficv as you stated the iacv has an electrical plug and the other does not. I found a real good write up with pics and it looked just like it. 3 10mm bolts holding it on, 2 8mm for the little side cover, 2 coolant lines and the little white thing that screws out im guessing is the actual valve. I took that out and took it apart and cleaned it with brake cleaner and got it all back on the car and when I started it up it idled at 2k for the normal 3-5 minutes its been doing. I dont know about how to post pics on here but I wish I could. I wonder why my fitv is on the side. Its directly underneath the tb bolted to the side like the tb is. Even in the write up it was pictured in a different place just as your saying. Is there anyway the could be some kind of a special b18b? Its running on a p75 which i believe is usdm. The only thing I cant understand is why it runs so good. I have had 2 90 tegs a 93 teg, and 2 95s that all ran absolutly great but not like this b18. The only thing thats done to it is an aem cai and 2 1/4 dynomax catback and it will litteraly eat tires of in 3rd
     
  9. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    I also forgot to mention that the date code on the head says its 93. If someone can tell me how to post pics on here I would be more than glad to do so.
     
  10. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Go to photobucket.com and load pics from computer to there.....then link the pics from there to here.

    2k is not a bad cold idle
     
  11. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    Ok thanks alot for all the help. Im going to easter dinner then ill be back to try the photo bucket thing. I will have to figure out how to post the links on here im not very computer litterate lol. I also found places where there is supposed to be vacuum lines so i will get pics of that up. Again thanks for all the help. Happy Easter!
     
  12. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    Dude i just looked at you hatch and your making me sick, lol. Thats what mine is supposed to look like. Talk about a cherry. Mine is originally red, but when i got it, it was primered grey and black and had no driver fender. Now its got a red fender so its grey, black, and red lol. Looks like shit really but I have only had it 4 days I already bought 2 quarts of satin black primer, just gotta get the money to pay my guy to shoot it. I really cant complain its completly rust free, got the jdm b18b and gsr trans. Shit I only gave 1400 for it. Gotta love spoiled rich kids lol. I talked him down from 2000. He said he needed 1400 for the down payment on his new lancer so naturally i pull out 1400 like here you go. After talking to his mommy for a minute, he came back outside and handed me the title. :lol:
     
  13. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    here is my diamond in the rough It now has a fender
    civ1.jpg

    civ2.jpg

    civ3.jpg

    civ4.jpg

    civ5.jpg
     
    Last edited: Apr 26, 2011
  14. stoopidb18eg

    stoopidb18eg New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 22, 2011
    Now hopefully its not raining tomorrow so I can get some pics of all the missing vacuum lines so I can get some help with those.
     
Verification:
Draft saved Draft deleted

Share This Page