1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18b swap into Eg cranks wont start!

Discussion in 'HYBRID -> EG-EK / DC' started by BlueDemon, Mar 23, 2014.

  1. BlueDemon

    BlueDemon New Member

    Messages:
    21
    Likes Received:
    2
    Joined:
    Nov 27, 2013
    1993 eg civic coupe dx manual trans swapped with a 96 integra b18b manual trans with correct ecu.

    Alright, got it started finally today after finding a ground issue! But now it wont start again..
    Entire fuel system is good and you can hear fuel pump going, spark is good obviously it started once, starter has been tested and battery is brand new. Compression is tested at hmotorsonline before they ship it out.

    Have some questions though
    1) Car had one map sensor that came with it, motor has one sensor installed which do I use? And which one of the wires am I supposed to use? (there's two sensors and two plugs)
    2) o2 sensor on the bottom does not hook straight up how do I fix this??

    I'm going to attach a video of it as well. I swapped this several weeks ago and yet to get it running...

    http://s303.photobucket.com/user/DwreckChev/media/VideoMar2330624PM_zps39ebfe06.mp4.html
     
  2. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,483
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    1) Use the MAP that came with the engine. The MAP and TPS plugs are identical IIRC, so make sure you don't have those switched. That might be enough to prevent it from starting.
    2) What exactly do you mean by doesn't hook up straight?
     
  3. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I think he means it's too short of a line. Just extend it and make sure it's out of the way of the header/heat.

    And I agree about the two identical plugs. Common that guys accidentally switch them.
     
    Matts96HB likes this.
  4. BlueDemon

    BlueDemon New Member

    Messages:
    21
    Likes Received:
    2
    Joined:
    Nov 27, 2013
    Oh man I hope its not just too short of a wire! That is too easy haha. Okay I will def swap those plugs and see what kind of difference it makes!!

    Got the car started and got to drive it for the first time ever around the block! Ran like shit and only starts like 1 in 20 times now but well see...
    The grounds up by the headlights weren't attached, I have never seen the end of plugs being the grounds before!!
     
  5. BlueDemon

    BlueDemon New Member

    Messages:
    21
    Likes Received:
    2
    Joined:
    Nov 27, 2013
    Got it running, think the fuel pump is bad so have a new Walbro coming in!

    The O2 sensor plug is two wire on my car and the actual O2 sensor which came with my swap is four wire. Should I just get a two-wire O2 and call it a day?
     
  6. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    what ecu are you using? it should match that's requirement
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Yes

    ECU and O2 need to be paired together like they were from the factory.
     
Verification:
Draft saved Draft deleted

Share This Page