1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18b wont idle

Discussion in 'General Tech and Maintenance' started by 94CivicSlow, Apr 12, 2005.

  1. 94CivicSlow

    94CivicSlow Senior Member

    Messages:
    458
    Likes Received:
    0
    Joined:
    Nov 9, 2004
    Location:
    B0ST0N
    Ive been chasing this crazy idle issue for months. Heres the facts.

    I disassembled the tb and the FITV and saw it was loose so tightened that white ring around the plunger.

    My IAC valve make a high pitched sound when the key is on but the car is not running. Unplugging the electrical connectors (obviously) makes the sound stop

    The car's cold idle fluctuates from 1500-3k until semi warmed up and it continuallly drops, stops fluctuating until it hits 500 rpm, from there it idles at 500 for 5 mins perfect, and then at real idle temp, the tach goes from 500 and drops to a bucking stall, then back up to 500 then bucks and usually stalls.

    Cleaning the IAC stopped the high pitched squeal when key is on and temporarily made the car run perfect. After 1 blast around the block, the idle returned to shit, and the high pitched sound returned.

    Timing is dead on 16 deg.
    Using chipped ecu and 403 cams.
    Valves adjusted recently.
    Cams at stock position
    Replaced TB and intake manifold gaskets.
    Checked vacuum lines.

    Problem has been intermittent before and after the mods, and now it just wont idle at all.

    I read all the idle articles. I tried all the tricks. Any shed some insight??
     
  2. 94CivicSlow

    94CivicSlow Senior Member

    Messages:
    458
    Likes Received:
    0
    Joined:
    Nov 9, 2004
    Location:
    B0ST0N
    I personally think its the IAC valve from that high pitched noise then cleaning it make that noise go away for a bit and restore stock idle..

    Comments?
     
Verification:
Draft saved Draft deleted

Share This Page