1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18b1 swap help

Discussion in 'HYBRID -> ED-EF / DA' started by Hondaandacura078, Jun 2, 2007.

  1. Hondaandacura078

    Hondaandacura078 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jun 1, 2007
    I have a 1991 integra and I put a 96-98 b18b1 in it but i'm having idling problems. It also smells like pure gas coming out of the exhaust like if its not burning it.

    I'm using a b18a1 distributor which doesnt fit properly on the b1 but seems to work fine.

    I'm also using a b18a1 intake manifold and i dont think thats a good thing because the b1 has bigger intake ports.

    The problem is that the fit valve has very strong suction and i know thats not normal because i never heard an integra hiss that loud during idle.

    when i cover the fitv with my finger the idle goes down but it still idles kinda high.

    I need help connecting all the lines to the intake manifold. I have all the vacuum lines right but i need help with the coolant lines to the aicv and the fitv.

    please help.
     
  2. delsol_racer

    delsol_racer Junior Member

    Messages:
    176
    Likes Received:
    0
    Joined:
    Aug 2, 2006
    Location:
    watsonville ca
    i would segguest getting tha right intake manifold cuz i have a diffrent one on my delsol and all it did was idel like shit and waste gas and once i changed tha manifold everything was great.
    also if u have a hole in it it will idel real high cuz its getting air from other places.
    one way to check is get card spray and spray it all over tha manifold and if it starts revving up then u know it has a hole or crack do this when its cold .
     
  3. frosty

    frosty Junior Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Sep 16, 2005
    its probably not the fitment of the manifold or distributor thats giving you problems.. i have a 90 teg with a b18b in it, used the stock IM and distributor and it has over 30k on it and has never had a problem. did you use any sensors from the b18b?
     
  4. Hondaandacura078

    Hondaandacura078 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jun 1, 2007
    I used all the stock sensors from the b1 i just used the wiring harness from the a1 and whatever was left over i left unconnected.
     
  5. Hondaandacura078

    Hondaandacura078 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jun 1, 2007
    Help

    can anybody help me??
     
  6. Hondaandacura078

    Hondaandacura078 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jun 1, 2007
    Problem Fixed

    I fixed the problem. I was missing a pcv valve
     
Verification:
Draft saved Draft deleted

Share This Page