1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18C into EJ1 with early redline problems

Discussion in 'HYBRID -> EG-EK / DC' started by SiRG EJ1, Oct 17, 2004.

  1. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    I just dropped a B18C (yes-- jdm gsr) into an EJ1. The redline should be 8200, and I am using the JDM P72 ecu. However, it is going to 6800, sometimes 7000, and one time it redlined at 7200. Do you think maybe the knock sensor wire I ran to the ecu could be causing it since my friend messed up the plug where the pin goes. It might not be making a good connection. I'm going to fix this, but are there any other suggestions as to what might be causing this? Thanks.
     
  2. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    ttt
     
  3. icustomxxxi

    icustomxxxi Junior Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Aug 11, 2003
    Location:
    LI, NY


    I had the exact same problem. JDM OBD II B18c into my 98 civic dx coupe (EJ). So anyway did you notice that there was only one vtec wire? Well that confused me and i call hmo, where i got my motor from, and they said thats how the JDM vtec works. They said i only need to hook up that one wire. It was either the solenoid or the oil pressure i forget which one.... well anyway I wire it to the wrong spot and i red lined around 7 and have no vtec. im assuming u did the same thing as i did so just switch up the vtec wire going to the ecu and your problem should be solved.
     
  4. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    I have obd1 and it was already wired for vtec.
     
  5. PhyRe

    PhyRe Senior Member

    Messages:
    1,002
    Likes Received:
    1
    Joined:
    Nov 14, 2003
    Location:
    ct
    i had that prob with usdm gsr in a 93 hatch and it was all about the wiring as soon as vtec was wired redline jumped from 7000 to 8600(chipped ecu). just switch the 2 wires. but if your already wired for vtec and its poping than i have no clue
     
  6. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    might as well try it... which 2 wires should i switch?
     
Verification:
Draft saved Draft deleted

Share This Page