1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18C1 problems

Discussion in 'HYBRID -> EG-EK / DC' started by bigpimphaha, Feb 5, 2005.

  1. bigpimphaha

    bigpimphaha Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Feb 5, 2005
    First off we got a b18c1 in a 97 civic dx. Problems are loopey idel and v-tech stopped working, at every stoplight its going from 1000 to 2000 and sometimes a little higher. I think the problem may be a vacum leak. There is a loud hissing noise that sounds like it is coming off of the fuel rail opposite of were the fuel goes into the rail. Problem is i flexed all the hoses i could find, felt every connection for air blowing or sucking, and i still cant find out were this hissing noise is coming from, so how exactly do i find it. Could that hissing be a fuel injector, as far as i know all the fuel injectors are working properly cause every cylinder is firing.

    After the swap my cel came on and it was an O2 sensor on the downpipe, but it didnt affect the car at all so i didnt worry about it. How many O2 sensors are there on my car and were exactly are they at, and could they be causing the loopey idel all of the sudden, even if they were already throwing a cel and the car was running perfectly.

    Vtech dosnt kick in at all anymore and i dont know why. I dont know to much about the vtech so i havnt done anything to diagnose that problem. But i want my vtech back and i need your help people. I see two plugs on the vtech and they been unplugged and plugged back in so it's not a loose connection with the plugs. Is there a way i can tell if vtech is trying to kick in (a clicking or a noise of some sort.) Is there maybe a fuse or something that controls the vtech. Any suggestions on these two matters would be greatly appreciated, and please leave detail so i totaly understand what your refering to. Oh yea what is a TP.
     
  2. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    throttle position sensor = tps, that could be the cause of you fluctuating idle. what ECU are you using? are you running obd1 or 2? chances are, you didn't add the proper wires to control the VTEC (not vtech, just so you don't get flamed)

    in the article section, there is a small one i wrote about my fluctuating idle problem, check it.. may give you some ideas...

    did you bleed the coolant system at all? air bubbles in there could cause the idle to fluctuate slightly after you release the gas pedal.. i had that problem when i did my lsvtec swap.
     
  3. bigpimphaha

    bigpimphaha Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Feb 5, 2005



    ECU im not sure came with the motor out of a 95 integra gsr, so you got me there. But vtec was working for 5 months after the swap now all of the sudden it dosnt. As for bleeding the coolant yea it got done. Like i said the car was running perfect for about 5 months after the swap then my idel started going crazy and now my vtec is out.
     
  4. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA
    Fast Idle Thermo Valve aka FITV was the cause of my high/low idle. Do a search for "idle" and you should be able to pull up about 5876587686858743 threads about it, or just read the article, it covers pretty much every cause and how to isolate the problem.
     
  5. cws13

    cws13 Senior Member

    Messages:
    484
    Likes Received:
    0
    Joined:
    Nov 15, 2002
    Location:
    Athens,GA
    A bad fast idle valve, IAC valve, or coolant temp sensor can cause this (I beleive that Honda calls it a thermo switching valve in case you run into a baffled parts dept.)
     
  6. tdg

    tdg Senior Member

    Messages:
    108
    Likes Received:
    0
    Joined:
    Apr 28, 2004
    FUCKING HELL it is VTEC
     
  7. Riceras

    Riceras Senior Member

    Messages:
    107
    Likes Received:
    0
    Joined:
    Dec 27, 2004
    Location:
    Dallas, Texas


    Says the Man with a stock SI Civic!

    And Dont you forget it! VTEC!!!
     
  8. tdg

    tdg Senior Member

    Messages:
    108
    Likes Received:
    0
    Joined:
    Apr 28, 2004


    Well, it does seem fucked up, doesn't it, that little old me with my STOCK car can actually spell VTEC when a dude who obviously knows a lot more about cars and actually does stuff with his can't even spell the most commonly mis-spelled Honda term.
     
  9. bigpimphaha

    bigpimphaha Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Feb 5, 2005





    Wow Who freakin cares, i asked for help with my car not with spelling, who's the real idiot when your posting dumb remarks like that.
     
  10. bigpimphaha

    bigpimphaha Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Feb 5, 2005
     
  11. bigpimphaha

    bigpimphaha Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Feb 5, 2005
    Ok well i put a new IM gasket on but it didnt fix my problem. Good News is the old IM gasket was shot and needed a new one anyways. The little whole inside the throttle body is constantly sucking air even after warmup, if i plug it with my finger the idel goes down to normal rpm's and stays constant. What exactly does that mean and what do i need to replace. Is that a bad IACV. Also i dont even have a FIT Valve at all, that seems kinda of odd, well at least it dosnt look like any FITV's i have seen. It suppose to be under the TB from what im told and there isnt one there.
     
Verification:
Draft saved Draft deleted

Share This Page