1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18c4 swap problems

Discussion in 'HYBRID -> EG-EK / DC' started by legionowo, Nov 25, 2009.

  1. legionowo

    legionowo New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Nov 25, 2009
    Hi everyone,

    guys i have a problem with my swap, as mentioned in the title, . The b18c4 engine is already installed in my EJ2 Coupe, where was previously d15b7. I have taken all from the english '99 donor namely:
    - engine with the engine harness
    - ecu
    - immobiliser (ring,key,immo ecu) and I conected it all according to this diagram
    [​IMG]
    The problem is, the engine wont start. After I turn the key on, the immo light flashes and than goes out after it reads the original key code(if the the key is out of the ring it blinks) so I assume the immo works correctly. I have checked the spark - it's not there.
    When I try with my previous ecu from d15b7 the engine starts and runs but oddly as it hasn't right maps inside.
    Note: There is one additional blk-grn wire comming from pin 2 of immo module. I was told it doesn't need to be connected now because originaly it goes to started relay which is not there in my car now.
    Do you have any ideas what could be the reason? I'm stucked with it from 5 days and I can't go on.:mellow:
     
  2. legionowo

    legionowo New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Nov 25, 2009
    I have figured it out!!! :D

    The topic may be closed. For future swapers...the immo diagram is correct!!!
     
Verification:
Draft saved Draft deleted

Share This Page